User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Emission control light

  1. #1
    Regular Member
    Join Date
    Apr 2008
    Location
    North Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy Emission control light

    Hi all.

    Had my Vectra 2.2 Elite for 3 weeks now (2003, Petrol, 24000 miles) - and no problems until now!

    Drove home tonight and the car was fine. I went out 20 minutes later and the dreaded emission control light came on (steady, not blinking) and is now permanently on.

    I drove about 5 miles to see if it cleared, but unfortunately not.

    Engine still seems ok, no loss of power at all and the light is always steady (never blinking, which would indicate possible cat damage).

    I know that it could be a number of things, including sensors etc - won't know for sure until the codes are read.

    Anyone got any ideas what to do next??

    I'm going to see if it goes out again tomorrow when I go to work - about 20 miles on the motorway.

    If the fault persists then I'm hoping I'm covered by the 12 month warranty that I took out (Perry's Silver). I just don't want to end up finding I'm not covered and having to pay a diagnostic bill, plus repair costs

    Regards,
    Shaun.

    P.S. Anyone got any comments either way about Perry's in Bury, or Perry's Swinton, as they're the two closest dealers to me and I'll probably end up going to one of them.

  2. #2
    Regular Member DeanF's Avatar
    Join Date
    Nov 2007
    Location
    Staffordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    More than likely the Oxygen sensor or the cat Sensor (Another 02 Sensor)
    As you say best to get the codes read then you will have a much better idea.

    Dean

  3. #3
    Regular Member sparky71a's Avatar
    Join Date
    Apr 2006
    Location
    At the Garage
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep as already said,that'll be the Lambada(oxygen)sensor and maybe the swirl valve too.Right this was my position until recently,Six weeks ago mine came on,and i put in the car,and the parts were ordered.
    That was six weeks ago and nothing,not a bean.Apparently as far as VX Dealerships are concerned there is no stock of these things any where at the moment,The light will eventually go off after 20 restarts,then it will just come back on
    Now this doesn't get any easier,because if the O2 sensors gone,your cat will be getting some random currents sent to it and no mistake
    The longer you remain without a fix,the very high risk you run of doing some serious damage to the cat.

    Also look at your BC,how is your MPG?
    Has it dropped faster than a pig chucked from a bomber?
    If so this could mean the swirl flaps are knacked,meaning that the mix of air and fuel is incorrect and your motor is using more fuel to compensate.

    I've got so fed up waiting,I changed my car for a 56 plate,YES this really was the reason for changing,as knowing VX i could see the wranglings up ahead with them after they eventually fixed it i drove it away only for the emmisions to fail in it's first MOT because of a knackered CAT that they are no longer taking the responsibilty for.I know call me a drama queen,but once bitten 'an all that.....
    oh and the best of luck.....This one's a bummer of a fix at the moment.

  4. #4
    Regular Member
    Join Date
    Apr 2008
    Location
    North Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks Dean & Sparky for the quick replies!

    Right, following what Sparky said above ("The light will eventually go off after 20 restarts,then it will just come back on") I just went for a drive of about 3 miles. I tried restarting the car about 6 times in total and the light has gone out. After another couple of re-starts and the return journey, the light has not come back on.

    So just a glitch? The pessimist in me thinks one of the sensors is on its way out and the light will come back again within a few days, but we'll see!

    Oh, and to answer your other question Sparky, the fuel economy hadn't dropped at all (I'm still getting about 36mpg ave).

    Regards.

  5. #5
    Regular Member sparky71a's Avatar
    Join Date
    Apr 2006
    Location
    At the Garage
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well if your fuels ok thats a good thing indeed!
    Mine dropped appaulingly around 22.1mpg on the day i sold her

    So i'll go for the lambada sensor,if you know someone who can fit it for you,the crazy thing is that there are lambada sensors out there to buy,the best price i got was around £56. Usually mid sixties is good,obviously if i'd been out of warranty this is the route i would have taken as they are pretty straight forward to fit.Butof course if you wait for a dealer to get you one....well.....say no more.

    But get it done sooner rather than later.

  6. #6
    Regular Member sparky71a's Avatar
    Join Date
    Apr 2006
    Location
    At the Garage
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Oh and one more thing,the first time the light went out,it stayed out for more than a week.When i sold her it didn't stay out for more than an hour.

  7. #7
    Regular Member
    Join Date
    Apr 2008
    Location
    North Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well, if it is the lambda sensor then I hope it's coverted under the warranty.

    Part of the warranty states "...electronic control unit and it's associated sensors...", so I presume this includes the lambda.

  8. #8
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    No swirly flaps on the Z22se, might be on the Yh but not se.

  9. #9
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Could be the EGR, can either get it tech 2'd out by Dealer or fix it yourself for about £15

  10. #10
    Regular Member
    Join Date
    Apr 2008
    Location
    North Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Drove to work & back today, round trip of 35 motorway miles and it hasn't come back yet. Engine still feels ok, power's still there etc.

    Finger's crossed!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Evaporative Emission Control?
    By kel123 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 31st August 2011, 19:07
  2. Emission control fault.
    By rogerp in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 31st August 2010, 17:05
  3. vectra c emission control system fault
    By cmh1990 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 21st July 2010, 20:12
  4. spanner light reset emission light now on HELP!
    By johnny boy67 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 7th December 2009, 12:07
  5. Emission control light on
    By PeteRs in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 5th May 2008, 16:07

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •