User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: 2.2DTI Power loss and starting problem

  1. #1
    New Member
    Join Date
    Apr 2008
    Location
    Bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry 2.2DTI Power loss and starting problem

    Hi, my dad has a 2.2DTI 2002 (140,000 miles) which I borrow sometimes when goin on a long journey and it has been having problems recently, after a while into a m-way journey it completely losses power, get to 50mph with foot right down on the floor and seems to have nothing left in it. When my dad comes to drive it he doesn't get the problem as he doesn't go on major roads on his commute to work. One time after I borrowed the car and experienced the problem, the next day the car failed to start, we towed it down the road and managed to bump start it and from then it started on its own again. The other day my dad has now experienced the problem when he went on a long trip and the next day it wont start, everything ticks over ok and sounds as it should but it just wont fire up. Going back to the loss of power problem, once you get off the m-way its very slow goin through the gears and doesnt build up much revs. Any ideas,

    Cheers.

  2. #2
    Regular Member Steel's Avatar
    Join Date
    Feb 2008
    Location
    Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : Z19DTH

    Year : 2005

    Default

    Couple of things, do you get an engine management light when it does it on the motorway? My old Vectra B used to do that but the light came on. Another thing it could be is the fuel filter, the housing can become distorted and allow air in which causes poor starting, my old Vectra had that as well, ran ok but was an absolute pig to start, especially if parked facing uphill. I found it had two seals on the filter so I changed the complete housing, wasn't a fortune and it cured the problem.

  3. #3
    Regular Member
    Join Date
    Jan 2008
    Location
    Tyrone
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just gotta say, I've got nearly identical problem today since I picked it up outta body shop after repairs. Slow as hell through the gears, but no engine management lights come on, and don't get the surge of power at 2500 revs that some mention when the egr valve may be done.

    I'm baffled, and I just know it's gonna be another nightmare when I leave into the garage in the morn to get sussed out. Just after getting her back after 5 weeks waiting for body repairs and now this!

    Let us know what info you find out, I will do same mate. cheers.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Starting problem 2.2DTi
    By Mogsy007 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 23rd August 2012, 13:24
  2. 2.2DTi loss of power, whooshing noise and excessive smoke
    By Mogsy007 in forum Engine & Drivetrain
    Replies: 15
    Last Post: 7th September 2011, 10:22
  3. 2.2dti strange noise and complete power loss
    By chrislloydie in forum Engine & Drivetrain
    Replies: 10
    Last Post: 28th May 2011, 16:09
  4. Intermittant power loss on 2.2DTi
    By stevemann in forum Engine & Drivetrain
    Replies: 24
    Last Post: 14th November 2010, 11:42
  5. Spanner light and slight loss of power 2.2dti
    By nickd_m in forum Engine & Drivetrain
    Replies: 15
    Last Post: 10th November 2008, 23:28

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •