User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: brakes,strange feel

  1. #1
    Regular Member kpf1grandprix's Avatar
    Join Date
    Mar 2008
    Location
    luton beds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default brakes,strange feel

    here's a strange 1,,,on my vec C when i apply the brakes,i get a weird graunching/grinding ,,not noise ,but feel through the pedal,not all the time,and not constant about halfway pedal travel ,,car has only done 1500 miles so isnt anything worn,done it since i picked it up,thought it might just be brakes wearing in,but is still there,,,anyone had this/or know?,,cheers

  2. #2
    Regular Member S14RRJ's Avatar
    Join Date
    Mar 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    wait a second, thats what i got, it happens when i have to brake very hardly, or sometimes a brake over rough ground, anyone help

  3. #3
    Regular Member kpf1grandprix's Avatar
    Join Date
    Mar 2008
    Location
    luton beds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by S14RRJ View Post
    wait a second, thats what i got, it happens when i have to brake very hardly, or sometimes a brake over rough ground, anyone help

    thats the one ,i thought it might have been the ABS but no light comes on,and its not as harsh as a normal ABS activation

  4. #4
    Regular Member S14RRJ's Avatar
    Join Date
    Mar 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah my abs flashes over potholes and stuff but no link to the brakes, hopefully someone will help

  5. #5
    Regular Member kpf1grandprix's Avatar
    Join Date
    Mar 2008
    Location
    luton beds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by S14RRJ View Post
    yeah my abs flashes over potholes and stuff but no link to the brakes, hopefully someone will help

    prob be a "querk and character " fault ,if i went to vx,
    lets hope someone has had and dealt with this.

  6. #6
    Regular Member S14RRJ's Avatar
    Join Date
    Mar 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    come on guys and gals help two Enthusiasts here !

  7. #7
    Regular Member penfold2000's Avatar
    Join Date
    Apr 2008
    Location
    Kettering
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I get a similar sort of thing on my old megane - feels a bit like abs but only does it when braking very lightly - I know its my CV joint going so poss could be the same on yours?

  8. #8
    Regular Member S14RRJ's Avatar
    Join Date
    Mar 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by penfold2000 View Post
    I get a similar sort of thing on my old megane - feels a bit like abs but only does it when braking very lightly - I know its my CV joint going so poss could be the same on yours?

    oh oh sounds like trouble

  9. #9
    Regular Member kpf1grandprix's Avatar
    Join Date
    Mar 2008
    Location
    luton beds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by penfold2000 View Post
    I get a similar sort of thing on my old megane - feels a bit like abs but only does it when braking very lightly - I know its my CV joint going so poss could be the same on yours?

    my cars only 6 months old

  10. #10
    Regular Member S14RRJ's Avatar
    Join Date
    Mar 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by kpf1grandprix View Post
    my cars only 6 months old

    yeah ouch, mines an 03 plate, so would expect it i think, di you buy yours new? i assume, if so have a word them. I think i need to check mine out with the garage then

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 14
    Last Post: 3rd September 2011, 20:23
  2. Strange clicky clunky noise when pressing brakes
    By Mogsy007 in forum Suspension, Wheels & Brakes
    Replies: 7
    Last Post: 16th September 2010, 01:47
  3. Do your brakes feel different in the recent cold spell?
    By MrT in forum Suspension, Wheels & Brakes
    Replies: 7
    Last Post: 12th February 2009, 17:45
  4. My Brakes dont feel quite right.....
    By spoons in forum General Chat
    Replies: 27
    Last Post: 1st December 2008, 01:49
  5. i feel sad
    By chrisgettings in forum General Chat
    Replies: 33
    Last Post: 13th December 2007, 18:44

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •