User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Oil Question(sorry guys)

  1. #1
    Regular Member Stuarty's Avatar
    Join Date
    Dec 2007
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Oil Question(sorry guys)

    I have got 5ltrs of mobil one fully synthetic 0W-40 in the garage and would like to know if it will be ok to use it in my CDTI 150 as it cost £45 was gonna throw it in with the my old when it went but thoughtid keep it for the next one.


    Cheers in advance guys

  2. #2
    Regular Member Steel's Avatar
    Join Date
    Feb 2008
    Location
    Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : Z19DTH

    Year : 2005

    Default

    Should be ok as I am pretty sure it will be API/ACEA CF/B3 spec but you can check on the container, wouldn't recommend it for the extended service intervals though.

  3. #3
    Regular Member Stuarty's Avatar
    Join Date
    Dec 2007
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Il go have a lok now cheers steel

  4. #4
    Regular Member Stuarty's Avatar
    Join Date
    Dec 2007
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep meets ACEA A3/B3/B4

    Cant find my oil filter though ****** typical lol!

  5. #5
    Regular Member Stuarty's Avatar
    Join Date
    Dec 2007
    Location
    Aberdeenshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ah well thats that ****ed then just had to remove the whole undertray to get to the sump and oil filter as my ramps are not high enough for the panel to open fully got the filter loose then went to take out the sump plug and yes you guessed it rounded off what a ****!Why do they insit of making parts like this out of playdough!!!!!!!!!!!!!!!!!!!!!!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. hey guys new here and have a question
    By grant2258 in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 15th December 2012, 22:25
  2. MOT question NI guys only
    By aerodynamic18 in forum Northern Ireland (RO - Vacant)
    Replies: 9
    Last Post: 8th February 2010, 22:46
  3. question guys
    By nph1 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 10th December 2008, 19:28
  4. Question for any I.T. Guys out there
    By Merick in forum General Chat
    Replies: 22
    Last Post: 26th April 2007, 09:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •