User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: vectra B "brake" light ?

  1. #1
    Regular Member moorlander's Avatar
    Join Date
    Apr 2008
    Location
    Staffordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra B "brake" light ?

    Hi,
    I have a vectra B 2002 (last of the old shape) and I have a dash light which is mostly on, sometimes intermittant which looks like a brake light (a circle with a semi-cirlce on each side (outside the circle.)) looks like this - (0) - this appeared when I first went to pull off after leaving the car for a week at the airport. the car "juddered" as though the handbrake was stuck on. my manual states "goto main dealer asap" as its in limp mode, but its not & I have been driving around like this for months with no obvious effects.
    the only thing I can think to do is to jack it up & remove the rear wheels to look at pads/sensors etc ? can anyone point me in the right direction/give me any advice ? many thanks

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    From what you're saying that's the low brake pad warning light. Only the front wheels have the sensors on.

    The limp mode light is something completely different (a picture of a car with spanner vertically through it)

  3. #3
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    272 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    Sounds like the rear brakes were stuck on which is possibly why it juddered when you pulled off, did it almost sound like a snapping noise when you moved off? The pad sensor wiring is in the front passenger wheel arm leading to the pads. Check to see if this lead is damaged or if you have actually got to the point where you do need new pads. The engine warning light on these is like a helicopter with a line through it further to the right on the dash.

  4. #4
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by plasma View Post
    Sounds like the rear brakes were stuck on which is possibly why it juddered when you pulled off, did it almost sound like a snapping noise when you moved off? The pad sensor wiring is in the front passenger wheel arm leading to the pads. Check to see if this lead is damaged or if you have actually got to the point where you do need new pads. The engine warning light on these is like a helicopter with a line through it further to the right on the dash.
    What me dear old dad said..:

    The EML on vectra B is indeed the helicopter style orange lamp.. the car and spanner is a vectra-C icon..

    the other light is indeed the brake pad level warning light..

  5. #5
    Regular Member moorlander's Avatar
    Join Date
    Apr 2008
    Location
    Staffordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for the replies, i will take the front wheels off (not the rear! haha)
    & have a look. I do also have the car/spanner light, (not the outline of the engine/helicopter light which i know is ECU) but I am sure that is because I never took it to the stealers for its 3rd year service (why bother when its out of warranty & I can do it myself better/cheaper!) oh, one thing I forgot to mention about the brake light is that it has a "!" in the middle of the icon.

    again, thanks for the replies

  6. #6
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    The car/spanner light isn't a service reminder light.

    As for the other light (which is now a different description to before) - then that is the warning light to indicate that either the handbrake is on, or that the brake/clutch fluid level is low. Before using the car again, check that the brake/clutch reservoir has enough hydraulic fluid in it.

  7. #7
    Regular Member moorlander's Avatar
    Join Date
    Apr 2008
    Location
    Staffordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Big Dave,

    yes brake fluid is ok (check levels quite often), so I presume it is a handbrake problem/sensor. what is the car/spanner light if not a service light ?

  8. #8
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    The info in a Vectra-B handbook says:-

    The symbol of a car with a spanner going through it is either a fault in engine electronics or transmission electronics. Electronics switch to emergency running programme. Fuel consumption may increase and driveability of the vehicle may be impaired.


    Later Vectra-B's had the word InSP appear momentarily in the odometer display when you first turned the key when a service was due. As yours is a 2002 model, it should have this feature.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "Winter" Wheels ? Are 19" Snowies best for the "Summer" ?
    By Woody in forum Vectra C / Signum Car Chat
    Replies: 21
    Last Post: 5th October 2012, 18:43
  2. I have a theory on "brake light out warnings"
    By wickedwillie in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 2nd February 2009, 22:03
  3. "BRAKE LIGHT" Message in display...
    By Westy SRI in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 12th December 2008, 23:35
  4. "Exclusiv" 1.9cdti Brake Mod ?
    By ANDY H137 in forum Handling & Braking
    Replies: 5
    Last Post: 8th January 2008, 00:57
  5. handbrake " CLUNK" how many clicks before ur brake holds?
    By Craig1985 in forum Suspension, Wheels & Brakes
    Replies: 21
    Last Post: 7th January 2008, 20:57

Visitors found this page by searching for:

zafira b handbrake light then limp mode

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •