User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: 2.0 DTI turbo problem

  1. #1
    New Member
    Join Date
    Mar 2008
    Location
    Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.0 DTI turbo problem

    Hi there, i have a 2.0 DTI veccy and most of the time it appears the the turbo isnt working and sometimes it does. I noticed the other day that the engine does smoke a little wen i put my foot down. Any suggestions?cheers

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    get the boost pressure sensor checked out..if it's giving bad readings then the turbo won't boost.. also check for any pinholes in the boost pipes or cracks in the rubber connectors of the small vacumn lines..

  3. #3
    Regular Member
    Join Date
    Sep 2005
    Location
    Nr Cardiff
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Boost hose split possibly?
    Does it make a loud "whooshing" noise when you boot it?

  4. #4
    Regular Member eaglepva's Avatar
    Join Date
    Jul 2007
    Location
    Up North
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check the rubber connectors on the vacume lines mine was running like the turbo had gone but it was the little rubber connector had cracked.

  5. #5
    New Member
    Join Date
    Mar 2008
    Location
    Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks guys, i shall check out the hoses. No 'whoosing noise' it does makes a very slight whistling sound at around about 2000 ish revs. To check the pressure sensor does it just need to be connected to a diagnostic machine? cheers

  6. #6
    Regular Member Matty H's Avatar
    Join Date
    Oct 2005
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Vibez_Uk View Post
    Thanks guys, i shall check out the hoses. No 'whoosing noise' it does makes a very slight whistling sound at around about 2000 ish revs.
    That IS the turbo working. You can hear it whistling at around 2k revs quite clearly. Sounds like it's working ok to me

  7. #7
    On a Sabbatical VauxVeteran's Avatar
    Join Date
    Mar 2006
    Location
    Nicking Ya Dinner.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Could be the air meter also, this loses all the power if it goes faulty.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 dti Turbo problem
    By Shortland78 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 18th February 2011, 14:34
  2. 2.0 Turbo problem
    By the stig in forum Engine & Drivetrain
    Replies: 7
    Last Post: 4th March 2010, 20:31
  3. Turbo Problem
    By sberrow in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 12th March 2009, 21:01
  4. problem with turbo or ?
    By chikenbud in forum Engine & Drivetrain
    Replies: 3
    Last Post: 1st February 2009, 16:03
  5. Turbo Problem...
    By dankidd in forum Engine & Drivetrain
    Replies: 3
    Last Post: 11th August 2008, 22:55

Visitors found this page by searching for:

vectra dti turbo problem

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •