User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: My Vectra C 2003 DTI cold starting problems solved hopefully

  1. #1
    New Member
    Join Date
    Jan 2008
    Location
    Exeter
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile My Vectra C 2003 DTI cold starting problems solved hopefully

    I have just had a very annoying problem with my car not starting. Course of action was as follows:-

    Problem 1
    Car had problems starting from cold and the engine management light came on for 20 seconds then went out. When the engine was warm car started with no problem. Suspected glow plugs were faulty, after taking it to the garage one glow plug was faulty and the control relay was faulty and was cooking the glow plugs.
    Glow plugs and relay replaced.

    Problem 2
    Got car back and still had problems starting it would turn over and took a while to fire up very jerkily starting. Suspected injector seals and run off pipes the problem was injector seals and were replaced as well as the run off pipes.

    Problem 3
    Went to pick up the car from the garage it started perfectly then stalled.
    Restarted the car it turned over but would not start, after quite a few goes it fired up with quite a bit of smoke out of the exhaust.
    Something still wrong. After an investigation by the garage over a week they discovered that there is a non return valve in the fuel pump. This was letting in air and the fuel was seeping back to the tank, this was why the car was not starting, they have just ordered the part and are expecting to fit it next week.

    Will update this post next week with result.


    From what I have read itís not good to keep starting the engine when the fuel leaks back to the tank. Can damage the engine.

    So to conclude with starting problems:-

    1)Glow plugs, EML comes on for 20 seconds then goes out.
    2)Injector seals/return pipes, seems common problem, jerky / problems starting
    3)Fuel pump non return valve, lets in air and fuel seeps back to tank.

    (I think this is the a problem that people have not identified, because from reading posts they are replacing the fuel pump, sounds expensive and unnecessary or using other methods to get round the problem like using a Citroen hand pump non return valve between the fuel pump and the tank, to get the fuel back to the engine. Or just living with the problem)

    Hope this might be of help to people so they donít have expensive garage bills.

  2. #2
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    sounds very costly now m8 hope you finaly get it sorted next week

  3. #3
    New Member
    Join Date
    Jan 2008
    Location
    Exeter
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Has been a bit costly

    The glow plug / timer relay was £170

    Injector seals and run off pipes were £430

    Hopefully not much more for fuel pump non return valve and fitting.

  4. #4
    Regular Member craigmerry's Avatar
    Join Date
    Jan 2008
    Location
    midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by jameso View Post
    The glow plug / timer relay was £170

    Injector seals and run off pipes were £430

    Hopefully not much more for fuel pump non return valve and fitting.
    I'm having the same trouble with 2002 dti, when its really cold. Isn't just possible to clean up the glow plugs like you can with spark plugs , or am i being thick. It's my first diesel.

  5. #5
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    nope, not possible to clean them up really...

    another set is only the real option..they're not dear but you do have to be very careful when you remove the old one's...

  6. #6
    New Member
    Join Date
    Jan 2008
    Location
    Exeter
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Think I have got to the bottom of cold starting problem

    I think I have found the source of my Vectra C 53 plate 2.0DTI cold starting problems.
    I was reading a copy of Car Mechanics magazine which featured a Vauxhall Astra estate diesel which had running problems. The magazine had contacted http://www.dieselbob.co.uk/ and they had suggested it was the EDC need repairing. On looking further on the website I discovered a Bosch VP44 fuel injector pump problem.
    These were fitted to my Vectra and have a habit of going faulty.
    I then found another web site http://www.dieselpumprepairs.com/ which described the cold starting problems I was experiencing. Once the car was warm then it starts fine. Because of the fuel injector pump it also makes you car light up the EML and go into limp mode randomly.
    The overhaul of the fuel injector pump is going to cost approx £600 and I'm thinking about getting it done as the rest of the car is OK.
    I have had the injector seals done and leak off pipes replaced so all the issues with the Y20DTH engine will be fixed.
    Hope this helps people as I'm quite glad I have got ot the bottom of it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 1.9cdti Cold Starting Problems
    By rjcotterill in forum Engine & Drivetrain
    Replies: 4
    Last Post: 7th June 2011, 16:15
  2. Problems starting 2.2 petrol in cold
    By phil_l875 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 20th December 2010, 13:45
  3. Cold starting problems!
    By tony750cc in forum Troubleshooting
    Replies: 5
    Last Post: 13th January 2010, 00:41
  4. My vectra problems/solved.
    By ectraz in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 23rd February 2009, 13:03
  5. Starting cold Problems
    By vectraspain in forum Engine & Drivetrain
    Replies: 0
    Last Post: 13th April 2007, 18:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •