User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Another 1.9 cdti 150 with no power, low rpm

  1. #1
    Regular Member
    Join Date
    Feb 2008
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry Another 1.9 cdti 150 with no power, low rpm

    Yep my sri 150 cdti is suffering from low rpm lack of power.No lights come up on dash , car runs fine , just no power below 2k rpm . Was fine till last week.Checked swirl valve operation and that seems fine . Had it in at the dealers today ,wtf , they told my wife there is nowt wrong because no codes come up on the diagnostics . Car has done 14k on a 56 plate. Dealer said that as nothing showing then they cant fix it . aparently they dont get paid to investigate a fault under a warranty , just fix what shows up when on the machine . Will be phoning vx tomorrow , see what they say. Could the egr valve be playing up? Can it be checked ? Can it be cleaned? Am i just imagining the whole thing ? arghhhhhhhh.

  2. #2
    Regular Member yorkiebar's Avatar
    Join Date
    Jun 2006
    Location
    N.IRELAND
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bigboss View Post
    Yep my sri 150 cdti is suffering from low rpm lack of power.No lights come up on dash , car runs fine , just no power below 2k rpm . Was fine till last week.Checked swirl valve operation and that seems fine . Had it in at the dealers today ,wtf , they told my wife there is nowt wrong because no codes come up on the diagnostics . Car has done 14k on a 56 plate. Dealer said that as nothing showing then they cant fix it . aparently they dont get paid to investigate a fault under a warranty , just fix what shows up when on the machine . Will be phoning vx tomorrow , see what they say. Could the egr valve be playing up? Can it be checked ? Can it be cleaned? Am i just imagining the whole thing ? arghhhhhhhh.
    is this not just the way the car is as mine is not that sharp below 1800 rev`s as well but after that goes fine.I think this has been said alot on this forum but am sure someone will let you know mate

  3. #3
    Regular Member Ian S100's Avatar
    Join Date
    Mar 2007
    Location
    Southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine has very limited acceleration below about 2200 & then takes off like a train, especially with the BSR remap. Had Vx look at it a number of times & been told 'there's nothing wrong with it' & 'they're all like that' - Basically, no warning lights means no fault

  4. #4
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    TBH i think its a trait of Vauxhalls and i blame rotten clutch. I feel if you don't give it juice, the engine hits a 'flat spot' til about 2,000rpom then it goes like stink.

    I think it's the cr4ppy clutch.

    Gazza4

  5. #5
    Regular Member
    Join Date
    Feb 2008
    Location
    grimsby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine doesnt have that much power under 2000rpm specialy if in the wrong gear but when it hits 2000 puls like a train must be the norm but then only had my 2006 plate for 2 weeks

  6. #6
    Regular Member
    Join Date
    Feb 2008
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Point taken guys , but car seems more flat than normal ! had it for nearly a year now

  7. #7
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default

    try the airbox mod.. I found it made a difference on my previous SRi

  8. #8
    Regular Member Ian S100's Avatar
    Join Date
    Mar 2007
    Location
    Southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Try the BSR mod.. I found it made a BIG difference.....

  9. #9
    Regular Member
    Join Date
    Feb 2008
    Location
    grimsby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is the airbox mod the one where you remove the intake pipe
    and does it make big difference if so will do when my k&n filter comes
    then bsr ppc remap

  10. #10
    Regular Member
    Join Date
    Feb 2008
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Eh , this seems to be turning into a tuning advice thread ,ha ha . Tbh its quick enough for me as it is . Does the airbox mod make it spin up a bit faster ?

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No power from 1.9 cdti 150
    By garetmcc79 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 1st April 2012, 08:04
  2. 1.9 cdti 150 no power
    By baz_cdti_sri_150 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 3rd October 2010, 15:00
  3. little power 150 cdti
    By smokydiesel in forum Engine & Drivetrain
    Replies: 13
    Last Post: 26th May 2010, 19:13
  4. 150 cdti with no power
    By pauly in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 7th January 2009, 00:23
  5. 150 Cdti down on power??
    By shrekster in forum Engine & Drivetrain
    Replies: 0
    Last Post: 7th December 2008, 00:19

Visitors found this page by searching for:

vauxhall vectra loss of power when accelerating

vauxhall vectra 1.9 cdti loss of power

vectra c 1.9 cdti lack of power

vectra 1.9 cdti low power

vectra c 1.9 cdtivectra c no powervectra c 1.9 cdti no boost1.9cdti weak boost at low rpmvauxhall vectra 1.9 cdti losing powervectra diesel no powervauxhall vectra no power when acceleratingvauxhall vectra 1.9 cdti diesel lost powervauxhall vectra 1.9 cdti clutch is lowvectra 1.9cdti 150 lack of powervectra cdti low boostvectra c no rev 2009Loss of power vauxhall vectra1.9 cdti low rpm powervectra down on power at low rpmVectra cdti 150 not acceleratingloss of power for signum 1.9cdti 07vectra c 1.9 turbo loss1.9 cdti low powervauxhall vectra 1.9 cdti 8 valve no accelerationz19dth feels down on power

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •