User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: intermitant rev and speedo

  1. #1
    Regular Member
    Join Date
    Feb 2008
    Location
    midsomer norton,bath
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default intermitant rev and speedo

    hi again!!!

    help needed please!!....i have my r reg sri vectra and the speedo and rev counter is playing up,sometimes its fine and all work fine,however sometimes i will get in and turn key to II possision and the rev needle will flicker and when started the speedo doesnt work and rev needle still slightly flickering.....water temp and fuel all working as normal and dash lights still work????

    please help and is starting to annoy!!!!!!!! thanks guys!!


  2. #2
    Regular Member jack's Avatar
    Join Date
    Feb 2008
    Location
    slaming doors since 1976
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    have you had your whole display unit checked via tech2? or anything checked on it?

  3. #3
    Regular Member
    Join Date
    Feb 2008
    Location
    midsomer norton,bath
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    no not yet, some1 mentioned the ABS sensor before to me??....does this ring any bells????

    could it be a faulty conection at back of dials u think???....if i go out in the car first thing in the morning it works fine,then drive it again shortly afer it plays up....if i leave the car for a few hours then its ok again?????

  4. #4
    Regular Member jack's Avatar
    Join Date
    Feb 2008
    Location
    slaming doors since 1976
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ye sounds like a faulty connection in the unit itself id say as the are cealled up id have a check on it get them to check all the dials and instruments work i wouldnt have said abs all your lights work in the display ok?

  5. #5
    Regular Member
    Join Date
    Feb 2008
    Location
    midsomer norton,bath
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yea ALL lights workin fine so i will take the dials out qand clean up connections on the back and see if that works!!#

    thanks 4 ur help...good man!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. intermitant wiper
    By Kaikianjames in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 4th January 2013, 21:25
  2. Intermitant ecu light on
    By sriandy in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 16th July 2012, 23:33
  3. intermitant power loss
    By Dougb in forum Engine & Drivetrain
    Replies: 1
    Last Post: 1st July 2010, 11:07
  4. intermitant starting problems
    By pward in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 25th March 2010, 21:05
  5. Intermitant Dial Failure
    By ballogie in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 23rd August 2007, 12:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •