User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Handling / Steering still not right

  1. #1
    Regular Member
    Join Date
    Jul 2007
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy Handling / Steering still not right

    Im getting a little fed up with this car now, I have replaced so many bits but still seem to be having more and more problems with the steering. The car seemed a bit iffy in the wet and I had only had the cars 6 months before so I thought I would treat it to some Eagle F1's. That seemed to help a little but still there was something not right with it. Next was a full set of Bilsteins B4's and new drop links, but still something didn't feel right. I then found that the inner track rods had slight play in them so these have been changed. I have just had the car put on a 4 wheel alignment at Vaxuhall in Telford as when I put the inner/outer track rods the alignment was wrong. Now the steering wheel is bang on center and goes in a perfect straight line ( it pulls a little to the left if you let go of the wheel, but im sure thats just the camber in the road).

    The car seems to drive ok and doesnt seem to wonder on its own accord, but my front wheels turn to what I can only describe as shopping trolley wheels when driving over a none perfect tarmac'd road, the front wheels seem so twitchy and as if they are going in different directions. But the odd thing that is happening now is that when the car has been stood for a long time, (when i get in first thing in the morning or when I get in after work) as soon as i move the steering wheel for the first time I feel like a rachet type of movement on the steering wheel, it never does it again until being stood for ages.
    This morning I pulled into the garage to check the tyre pressure (which where fine) but when I reversed out of the bay I had to put the steering wheel on full lock (as a car was filing up with petrol behind me), once I had reversed on full lock I put it into first gear and drove forward and turned the steering wheel the other way (as you do) and i felt a longer rachet type movement through the steering wheel, like when it has been stood for ages but rather than maybe 2 or 3 clicks I felt maybe 7 or 8 rachet type movement.

    Sorry for the long post but I have no idea what the problem is with this car. Could I have a faulty rack as im a little lost as to what else could be wrong.


  2. #2
    Regular Member wardy's Avatar
    Join Date
    Sep 2006
    Location
    Chichester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I felt something similar when pulling out (reversing) from my drive. Had it on full lock, and as I started to pull forward I had a judder through the steering wheel. Do idea what it was, but it only happened on Monday after the car had been stood all weekend.

    I too am getting fed up with suspension noises, crunching & banging. VXL keep telling me theres nothing wrong with it, but clearly there is. Never have another Vec I'm afraid.

  3. #3
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Checked the oil in the electric power steering bottle although this should never need topping up. Might have a leak?

  4. #4
    Regular Member simac's Avatar
    Join Date
    Sep 2006
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah, it's worth checking that out. The top on mine somehow worked loose and some fluid leaked out. Was only a small amount but enough to stop it showing up on the dip stick.

  5. #5
    Regular Member
    Join Date
    Jul 2007
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ive just checked it and its right up to the max mark

  6. #6
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Tyre pressures correct?

  7. #7
    Regular Member
    Join Date
    Aug 2006
    Location
    Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Fiat

    Trim : Panda 100HP

    Engine : 1.4

    Year : 08

    Default

    What about a cv joint binding?,that'll make the steering feel bad.

  8. #8
    Regular Member
    Join Date
    Jul 2007
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep tyre pressures are all at 32, those where checked this morning.

    CV joint, hmmm, whats the best way to test the CV joint?

  9. #9
    Regular Member
    Join Date
    Aug 2006
    Location
    Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Fiat

    Trim : Panda 100HP

    Engine : 1.4

    Year : 08

    Default

    You could try jacking it up and put it on either lock and spin the wheel by hand,you might feel a difference or take for a drive a see if you get a clicking from the front as you go round left and right hand bends (this normally indicates a worn cv but worth checking).

  10. #10
    Regular Member
    Join Date
    Jul 2007
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I dont put any music on these days as im always listening for any unusual noises, none heard so far, which is whats doing my head in. I'll try driving round in circles on an industrial estate where I live tonight and listen for any clicks. I'll let you know, thanks for the suggestions.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Handling?!?
    By krzyzu in forum Handling & Braking
    Replies: 0
    Last Post: 17th February 2009, 22:10
  2. vectra handling
    By willie76 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 9th April 2008, 21:28
  3. Handling help
    By crucial in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 25th December 2007, 01:05
  4. handling
    By brant2474 in forum Handling & Braking
    Replies: 8
    Last Post: 12th December 2007, 23:40
  5. Handling?
    By danny2.2 in forum Vectra C / Signum Troubleshooting
    Replies: 15
    Last Post: 19th December 2005, 22:39

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •