User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Petrol Direct 2.2 Signum Elite

  1. #1
    Regular Member Small Racer's Avatar
    Join Date
    Jan 2008
    Location
    Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Petrol Direct 2.2 Signum Elite

    I see many threads on CAR with SPANNER and each answer seems to be for a 1.9 DTI. I have just picked up a new (second hand) from Dealer - Petrol Direct 2.2 Signum Elite, 55 plate.

    Insert key and turn to first point, all lights on, pause 1-4 seconds all lights out except:
    Red Hand Break
    Orange Engine
    Orange CAR with SPANNER through the middle of car)

    Turn key to next point to engage starter and engine starts, all lights now out except Red Hand Break. CAR with SPANNER does not come on while driving. Car drives like a dream.

    I said to main dealer mechanic ' is the CAR and SPANNER meant to go out with the rest of light BEFORE the car is started?

    NO both said - it is meant to stay on till the engine starts - it checks the electronics.

    MY QUESTION -
    Is this correct or should I ask them to think again?

  2. #2
    Regular Member BIG NEIL's Avatar
    Join Date
    Oct 2007
    Location
    Back in Belfast!!!!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the spanner light on my signum is never on unless it needs a service

  3. #3
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Small Racer View Post
    I see many threads on CAR with SPANNER and each answer seems to be for a 1.9 DTI. I have just picked up a new (second hand) from Dealer - Petrol Direct 2.2 Signum Elite, 55 plate.

    Insert key and turn to first point, all lights on, pause 1-4 seconds all lights out except:
    Red Hand Break
    Orange Engine
    Orange CAR with SPANNER through the middle of car)

    Turn key to next point to engage starter and engine starts, all lights now out except Red Hand Break. CAR with SPANNER does not come on while driving. Car drives like a dream.

    I said to main dealer mechanic ' is the CAR and SPANNER meant to go out with the rest of light BEFORE the car is started?

    NO both said - it is meant to stay on till the engine starts - it checks the electronics.

    MY QUESTION -
    Is this correct or should I ask them to think again?
    they are correct.....no fault there..

  4. #4
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by Small Racer View Post
    I said to main dealer mechanic ' is the CAR and SPANNER meant to go out with the rest of light BEFORE the car is started?

    MY QUESTION -
    Is this correct or should I ask them to think again?
    It should go out after approx 5 seconds. The reason it's remaining on is that there is a stored fault code in the ecu. I'm not sure after so many clean start ups (by that I mean no faults are logged when you turn the key) or number of days have passed before the fault code will be automatically deleted. My gut feeling is that it's time related rather than key turns related if no further fault codes crop up.

    See a previous thread of mine where I had an immobiliser related fault. I eventually got the car started but the car/spanner light remained lit until the engine was started for approx 30 days. After that it now goes out before the engine is started.

    http://forum.vectra-c.com/showthread.php?t=37845

    .

  5. #5
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by BIG NEIL View Post
    the spanner light on my signum is never on unless it needs a service
    That's a different light to what the OP is talking about though.

  6. #6
    On a Sabbatical
    Join Date
    Dec 2007
    Location
    south wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mines a 2.0t pre face and i never see the spanner light,when my dump valve broke i replaced it,started the engine and still in limp mode,i thought i haven't solved the problem pulled over and disconnected battery put terminals back on it and it was fine,haven't seen spanner light since when mine needs a service it comes up with SERV or somthing like that in the millage display,did you know that if your car goes low on oil before the light comes on it goes into limp mode no spanner light or nothing

  7. #7
    Regular Member Small Racer's Avatar
    Join Date
    Jan 2008
    Location
    Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Many thanks for your help chaps. I went to the Dealer and they put it on the T2 - found stored codes ref low voltage (battery was dead at first test drive).
    They cleared the stored codes, and now all lights come on at first point and all go out EVEN the CAR WITH THE SPANNER goes out BEFORE I move the key to ignition point. Then the engine light goes out and off I go into the sunset.
    Special thanks to the mechanics at main dealer.

  8. #8
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by vectrac20tsri View Post
    haven't seen spanner light since when mine needs a service it comes up with SERV or somthing like that in the millage display
    You're referring to the service light, which is in fact an oil can with a spanner through it or the word InSP in the odometer display (depending which service regime you're on - ie, fixed or ECOService-Flex)

    What the OP of this thread is referring to is the Engine Electronics / transmission electronics / immobiliser fault light, which is a picture of a car with a spanner vertically through the middle of it.

  9. #9
    Regular Member Signum_CDTI's Avatar
    Join Date
    May 2007
    Location
    Somewhere and Nowhere....
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2 View Post
    they are correct.....no fault there..

  10. #10
    Regular Member Small Racer's Avatar
    Join Date
    Jan 2008
    Location
    Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Many thanks - but like I said the vx dealer mechanics found low voltage faults recorded in the ECU. They cleared these and now the CAR with a SPANNER goes out with the rest of the lights (except the Orange Engine light !! ) BEFORE I move the key to the ignite position.
    Car drives like a dream and I am glad that they have cleared this stored fault code.
    Shall we say thread closed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. whats mpg like on a 2.2 direct petrol signum
    By vo04lan in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 2nd August 2012, 19:34
  2. signum 3.2 elite petrol
    By iam2103 in forum Engine & Drivetrain
    Replies: 18
    Last Post: 9th February 2010, 12:37
  3. Signum 2.2 direct petrol. Timing Chain
    By barneyp06 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 18th January 2010, 12:19
  4. Signum 2.2 direct petrol. Timing Chain
    By barneyp06 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 17th January 2010, 12:28
  5. 2.2 Direct Signum Petrol - Loss of power
    By Binksy2.2Direct in forum Engine & Drivetrain
    Replies: 5
    Last Post: 9th July 2009, 00:33

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •