User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Emission light V6 CDTI

  1. #1
    On a Sabbatical
    Join Date
    Aug 2006
    Location
    EVERYWHERE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Emission light V6 CDTI

    A couple of times just recently the emission light has come on.Sometimes when accelerating steadily uphill and others when the car is being reversed onto the driveway using nothing more than tick-over!

    Usually just switching off and waiting a few minutes and switching on again will solve the problem.But once or twice I have had to warm the engine right up and then switch off and restart for the light to go off.Usually it is only the emission light that comes on (no spanner light).

    Any ideas?

  2. #2
    On a Sabbatical
    Join Date
    Jun 2005
    Location
    Failsworth, Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the emission light come on on my CDTi 150 and it turned out to be a faulty injector. It could be a number of things though matey.

    If the emissions light ever flashes on anyone you must pull over and get recovered as the CAT will be getting damaged.

  3. #3
    On a Sabbatical
    Join Date
    Aug 2006
    Location
    EVERYWHERE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Good advice!

    There's never any excess black smoke or other symptom.It did once drop into 'limp mode' when the light came on.But otherwise runs as normal,even with the light on!

  4. #4
    On a Sabbatical
    Join Date
    Jun 2005
    Location
    Failsworth, Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I simply don't know enough about the V6 CDTi to help enough I'm afraid.

    The only thing I can think of about the V6 CDTi is that the little valve that sits on top of the ECU can become blocked, but I can't remember what the symptoms are/were. One of the V6 boyz or girlz will be along shortly I'm sure.

  5. #5
    Regular Member alanv6's Avatar
    Join Date
    Nov 2007
    Location
    weymouth, dorset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My mate at work runs an 05 sri v6 cdti and has just experienced a simular fault on his, seems to be over boosting when watching data list on tech 2,spoke to technical yesterday and could have a turbo fault which is common on these,seems the variable vain part of the turbo sticks internally causing overboost, luckily his is still under warranty andhaving new turbo next week May be worth getting it checked out.

  6. #6
    On a Sabbatical
    Join Date
    Aug 2006
    Location
    EVERYWHERE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by alanv6 View Post
    My mate at work runs an 05 sri v6 cdti and has just experienced a simular fault on his, seems to be over boosting when watching data list on tech 2,spoke to technical yesterday and could have a turbo fault which is common on these,seems the variable vain part of the turbo sticks internally causing overboost, luckily his is still under warranty andhaving new turbo next week May be worth getting it checked out.
    I had the turbo and sensor replaced on mine last Summer,so it should still be covered by 12 month warranty.Not had any problems over the last few days,but I'll probably get it checked out anyway.

  7. #7
    Regular Member
    Join Date
    Dec 2007
    Location
    AYLESBURY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Had same symptoms on my v6 cdti on a 54 plate,turned out high pressure fuel pump was under fuelling,hence emission light comes on.Took garage 3 attempts to diagnose problem [no fault codes come up]only done 30,000 miles brand new pump on warranty.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Emission light on
    By Porl in forum Engine & Drivetrain
    Replies: 15
    Last Post: 11th February 2013, 23:10
  2. Exhaust emission light on 1.9 CDTi
    By Andy R in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 13th November 2012, 21:42
  3. spanner light reset emission light now on HELP!
    By johnny boy67 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 7th December 2009, 12:07
  4. Emission light 1.9 cdti 120 helped
    By Kieran1981 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 17th July 2009, 18:59
  5. help with emission light
    By wilsons 1.8sxi in forum Engine & Drivetrain
    Replies: 4
    Last Post: 10th July 2008, 02:02

Visitors found this page by searching for:

v6 vectra cdti emissons light on whilst engine running

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •