User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: problem car and spanner light

  1. #1
    New Member
    Join Date
    Feb 2008
    Location
    redditch
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default problem car and spanner light

    hi all
    had a vectra c 1.8LS for a year now and no problems up till now.About a week ago the mrs popped out and i soon got a phone call saying this light was on and it wouldn't start but after a few trys it fired up.Now i thought it was just a little blip until yesterday she went out to it and the same happened, luck has it i was on hand to see it.The only way to describe it is its a fast turnover with no compression but if you keep tryin it will fire up and the light goes out(never comes on when the engine is running).the idle tends to bounce about abit most of the time.Oh better mention the the petrol light was flashing both times this happened

    hope someone can point me in the right direction

    cheers
    andy

  2. #2
    Regular Member J.P.'s Avatar
    Join Date
    Feb 2008
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had a similar problem just before Christmas, I would put the key in and a car and spanner would light on the dash and the car would not start, then after a few tries it did and the light goes out, also had the flashing fuel light. Then one day it just would not start at all!!
    1st Thing...DO NOT GO TO A MAIN DEALER, that was my first call they tried to charge me £1599. then I got a local garage to pick it up and take it to a chap they new in Essex. He cleared and re-programmed the ECU with 2007 software, this cleared the problem, that and a new key came to under £200.
    After looking through the internet I found out that on the 1.8 Vectras the ECU is mounted on the engine block and after a few years of getting hot and cold, it starts sending out wrong messages to the sim boxes in the car, I believe the 1.8 has at least 3. Mine kept telling the sim box in the ignition that it was not the right key and kept blocking it by not turning the immobilizer off.
    I don't know if this is of any help, good luck, I hope you get it fixed soon.
    Last edited by J.P.; 17th February 2008 at 23:26.

  3. #3
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yep, first call is a session on a decent code reader..

  4. #4
    New Member
    Join Date
    Feb 2008
    Location
    redditch
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ok thanks lads will get a code for it this week and see what happens and post an update but not had a problem with it over the weekend (sods law)


    cheers
    andy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Car/Spanner Light Problem
    By yates in forum Engine & Drivetrain
    Replies: 4
    Last Post: 4th December 2012, 23:03
  2. Another Spanner light problem
    By robhullfury in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 6th February 2011, 21:12
  3. 2.0l DTI LS estate, spanner light problem.
    By mick 1986 in forum Vectra C / Signum Car Chat
    Replies: 46
    Last Post: 12th December 2010, 18:45
  4. Spanner Light Problem
    By levy9 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 23rd August 2009, 14:39
  5. Spanner light maybe a steering lock problem?
    By zipfree in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 4th March 2008, 08:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •