User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Faulty EGR Valve

  1. #1
    Regular Member Vecmaniac's Avatar
    Join Date
    Oct 2007
    Location
    Morpeth, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Faulty EGR Valve

    Hi all

    Just out of curiosity...

    How many out there have had the faulty EGR valve problem on their CDTI?

    What mileage was showing when the problem showed up?

    I have a sick 1.9 CDTI which is a bit dodgy on take off and have been waiting for two weeks for a replacement valve.... Davidsons of Morpeth told me that they had some in but they have all been used and they are having major difficulties getting new ones in stock... Thought I would try another dealer so I went to Milburns at Ashington but they have the same problems with getting them too.

    The lad in Davidsons (Nice chap) told me that they have three other customers waiting for replacement valves!!!

    Is this an epidemic?

    If it is and the fault makes the car dangerous to drive (I.E. pulling out of junctions etc) shouldn't there be a recall??

    Here's praying they're in soon (For my own safety at road junctions... I don't think that the clutch can take much more of this!!!)

  2. #2
    Regular Member dave t's Avatar
    Join Date
    Mar 2007
    Location
    Morpeth Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Andrew i'll lend you my dti

  3. #3
    Regular Member Maverick's Avatar
    Join Date
    Jun 2005
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    EGR valves are on back order from the factory, it appears so I am told that EGR vavles fail on cars that do the lower mileage.

    In 120,000 miles between three different 1.9 CDTi 150's I have never had an EGR fault.

  4. #4
    Regular Member
    Join Date
    Feb 2008
    Location
    grimsby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i just got my vectra but only use it 1 in 3 day do about 50 miles on that day down motorway would you say my egr should be ok for a long time.or would you recommened a strip and clean

  5. #5
    Regular Member Vecmaniac's Avatar
    Join Date
    Oct 2007
    Location
    Morpeth, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Called in to Davisons to find out if any valves had come in... Had to wait a bit as there was a customer in front of me with, guess what... yep, a faulty EGR valve!! Anyway once they had dealt with them I got the news... Yippee!!! My valve was in stock and would be fitted today!!!

    Just got the car back and had forgot just how quick it is...

    Thanx for your offer Dave!!

  6. #6
    Regular Member
    Join Date
    Dec 2007
    Location
    carlisle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    got 42000 miles on mine and had the egr valve replaced twice now, the first one was replaced after only having been on 6 weeks, wasnt impressed! last one was fitted at Davidsons (wouldnt go any where else even with the 120 mile round trip)

  7. #7
    Regular Member andy.l's Avatar
    Join Date
    Jun 2005
    Location
    Wirral / ellesmere port
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia tourer

    Trim : elite

    Engine : 2.0 cdti 160

    Year : 2011

    Default



    mine has been replaced under warranty as mine failed about
    a month ago,for some reason it used a fair bit of fuel aswell
    when it was knackered.

  8. #8
    Regular Member bruceybonus's Avatar
    Join Date
    Jun 2005
    Location
    Preston Area
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine failed.. 3.0cdti- 78k miles.... 600quid to get it fixed

    just out of interest.. how much was it for 1.9... the valve and gasket for mine was £500!

  9. #9
    Regular Member Vecmaniac's Avatar
    Join Date
    Oct 2007
    Location
    Morpeth, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    £500!!!!I priced up a valve at Milburns (Ashington) and they said £117!! Didn't mention anything about a gasket though so probably a bit more than that.

    My veccy used loads of fuel while it had Egrvalvitis not really while under hard acceleration more just general driving (Like I normally do....)
    Last edited by Vecmaniac; 13th February 2008 at 21:14. Reason: just adding a bit!!

  10. #10
    Regular Member dave t's Avatar
    Join Date
    Mar 2007
    Location
    Morpeth Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Normal acceleration you

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brake servo Valve (one way valve)
    By Tank988 in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 29th October 2012, 19:48
  2. Fault code po403 exhaust gas recirculation valve.faulty.
    By Dobs in forum Engine & Drivetrain
    Replies: 1
    Last Post: 8th September 2012, 13:37
  3. Replies: 6
    Last Post: 29th July 2012, 13:52
  4. Faulty EGR Valve
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 24th January 2010, 20:31
  5. Driving on Faulty EGR Valve?
    By MikeO in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 9th January 2010, 01:47

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •