User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Squeaky Rear

  1. #1
    Regular Member
    Join Date
    Apr 2007
    Location
    Larkhall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Squeaky Rear

    Having driven through several mini-lake type puddles the rear of the car started squeaking and i found some drops of water in the fuse box and light cluster area on the passenger side.

    Obviously the water has got in through the wheel arch due to the amount of water in the puddle but any ideas what was causing the squeaking??

    It seems to have stopped now though.....

  2. #2
    Regular Member
    Join Date
    Jul 2007
    Location
    west yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    may have just been a bit of grit on disks or on shockers it should be nothing to worry about it used to happen on my landrover defender all time now that sweaked if it saw a pudle never mind when i hammered it through lakes

  3. #3
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sound like they had to dry out abit m8 just check that they still have copper slip on the metal part of the pads

  4. #4
    Regular Member
    Join Date
    Apr 2007
    Location
    Larkhall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I kind of guessed it may have been the shocks - as the brakes were fine and no noise came from them

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. squeaky fan
    By stu_c in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 8th February 2012, 22:12
  2. squeaky rear end
    By porthy-t in forum Suspension, Wheels & Brakes
    Replies: 4
    Last Post: 17th October 2009, 06:37
  3. squeaky rear o/s brake, 1.9 150ps 07 reg
    By mitch in forum Suspension, Wheels & Brakes
    Replies: 7
    Last Post: 28th July 2009, 20:18
  4. squeaky rear - a new noise to discuss
    By Agoogy in forum Suspension, Wheels & Brakes
    Replies: 1
    Last Post: 7th March 2009, 19:59
  5. Squeaky rear end!
    By DNS in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 18th October 2008, 01:46

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •