User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Exhaust Control Indicator

  1. #1
    Regular Member D-S-Dave's Avatar
    Join Date
    Jun 2006
    Location
    Home init
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Exhaust Control Indicator

    Emission control light came on tonight. Drove back from brum with it on all the way. Wasn't sure if it being on was normal. Looked it up in the manual and it says the permissible emission limits may be exceeded. Light didn't go out from starting. Tried starting the car a few times and its still on.

    Any ideas.

    Cheers Pugster

  2. #2
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Firstly, if it starts to flash then you should stop driving the car as you're in danger of damaging the cat.

    Secondly, disconnect the battery for a bit to reset it and see if it comes on again. If not, then don't worry about it. Sometimes cold weather can just cause the exhaust mixture to be such that it sets the sensor off.

    If it does come on again, then off to a dealer to see what the problem is. It could be a multitude of reasons. All it's indicating is that the sensors are picking up readings that are out of range - it could be the lamda sensor playing up, or a multitude of other possible reasons. You'll really need to get the car read to see what codes are stored.

  3. #3
    Regular Member D-S-Dave's Avatar
    Join Date
    Jun 2006
    Location
    Home init
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers Duncan.

    Battery comes off in the morning. I'll keep you posted.

    Thanks again.

    Pugster

  4. #4
    Regular Member D-S-Dave's Avatar
    Join Date
    Jun 2006
    Location
    Home init
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Good news

    Did as Duncan said and disconnected the battery to reset the codes. Left cables off for half an hour. Whilst waiting fitted some chrome air vent wheels (pics later). Re-connected cables and still had the warning light as before (oh bother I said). As I'm the sort of person not to be beat, started looking at the lamba sensor and tracing the cable back. Took the engine cover off and the cable came to a plug. All seems ok, just made sure all plugs were home and wiggled the cables. Still no joy.

    Oh well a trip to the dealers tomorrow then or so a thought.

    Went to pick Mum up and the warning light now goes out after the engines started. Tried this several times and its still going out.

    Strange things happen to those who wait.

    Cheers one happy Pugster

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Control indicator for exhaust
    By Dazr82 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 9th July 2011, 23:30
  2. 3.2 V6 control indicator light
    By ozziemokuy in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 15th January 2010, 14:33
  3. Electronics control indicator on
    By sharpo in forum Engine & Drivetrain
    Replies: 1
    Last Post: 21st June 2009, 22:08
  4. Control indicator for the exhaust...
    By johnny in forum Engine & Drivetrain
    Replies: 6
    Last Post: 25th January 2008, 22:32
  5. Help! - Control Indicator for Exhaust Warning Light
    By Madders in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 8th December 2007, 20:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •