User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: cabin fan problems

  1. #1
    New Member
    Join Date
    Jul 2007
    Location
    Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default cabin fan problems

    Hi, I helped my friend fix a few problems with his 1998 1.8 Vectra Artic today, one we could not fix though, when you set the cabin fan to come on it only works on the highest setting (I think setting 4), not on any of the others, when I switched the air con on the fan should start at setting one automatically and it did not which makes me think it is not the heating control switch unit but something else since the switch is not involved when the air con is turned on. Any one got any pointers??, fan unit/ switch unit or something more complicated with electrics, if I know which bit is likely faulty could probably fix, all the parts look relatively straight forward to replace.

    All suggestions very welcome, any body fixed anything like this??

    Rgards
    Kevin

  2. #2
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sounds like the heater switches have packed up m8

  3. #3
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Resistor pack has failed if it's only working on fastest speed. Located near to where the blower motor is.

  4. #4
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    As big dave says, sounds like the resistor pack. Have a look through this thread.

  5. #5
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    I was going to point him towards that thread (in fact I did then edited it out again) once I realised the OP friend has a Vectra-B and not a Vectra-C. Didn't know if the location of the blower motor was the in the same place?

  6. #6
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Quote Originally Posted by Big Dave View Post
    I was going to point him towards that thread (in fact I did then edited it out again) once I realised the OP friend has a Vectra-B and not a Vectra-C. Didn't know if the location of the blower motor was the in the same place?
    Good point! Will have a poke around an see if its in the same place.

  7. #7
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Right, looking at this very bad pic it looks like you gain access through the scuttle panel (Vec B owners please confirm).
    It says" remove clean air filter housing, disconnect fan motor wiring harness plug, lift out fan motor, pull series resistor for fan motor upwards initially and then pull out to the side, then release wiring harness plug and disconnect from the fan motor series resistor. Hope its of some help, ive never had a b.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. exhaust fumes in cabin
    By chrislloydie in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 26th January 2013, 07:33
  2. Cabin Filter
    By steve533 in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 15th March 2011, 11:26
  3. Smell in Cabin....
    By unreal_event_horizon in forum Engine & Drivetrain
    Replies: 2
    Last Post: 1st February 2011, 00:57
  4. Fumes in the Cabin
    By bennyk in forum Diesel Engine related
    Replies: 7
    Last Post: 11th December 2007, 13:54
  5. cabin noise
    By scott_150cdtisri in forum Bodywork & Interior
    Replies: 5
    Last Post: 14th February 2007, 00:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •