User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Heater Removal

  1. #1
    Regular Member
    Join Date
    Oct 2007
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heater Removal

    Does anyone have instructions on how to remove and replace the heater on a 2003?

    thanks

  2. #2
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Which bit? Do you just mean the control bit on the centre dash?, or the matrix and other stuff?

  3. #3
    Regular Member
    Join Date
    Oct 2007
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Duncan View Post
    Which bit? Do you just mean the control bit on the centre dash?, or the matrix and other stuff?
    The actual motor itself. decided today of all days would be the day to stop working. ive checked the fuse - thats ok, the aircon and windscreen lights on the dash still work when i press them... just getting no air at all on any of the 1-4 settings. up until last night it was all working great (apart from the occasional whining noise coming from the motor on the lower settings).

    Im desperate to get this fixed as i drive a round trip of 160 miles a day and its ****** freezing.

    thanks

  4. #4
    Regular Member SignumPhil's Avatar
    Join Date
    Jun 2005
    Location
    Luton, Beds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    haven't some folks had trouble with fan switches?

    Phil

  5. #5
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep, all to do with water ingress and a resistor getting fried. Needs a little hole drilled and a new resistor fitted - could be that. I can't recall the exact symptoms, but I'm sure it was that the fan only worked above #4 setting. A forum search should track down the threads.

  6. #6
    Regular Member
    Join Date
    Oct 2007
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the resistor issue a while back - the fan would only work on setting 4. Changed the resistor pack for a new one and it fried within 10 minutes.
    I was told to bridge the resistor connection to get it working which it has done until last night.
    Now when i turn the switch i hear a click from behind the glove box, but nowt else happens.

  7. #7
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The click from behind the glove box is a symptom of when people have had servo motor issues. Have a search for that and see if it tallies up with what you're experiencing.

  8. #8
    Regular Member
    Join Date
    Oct 2007
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Would this servo be likely to cause the blower to completely stop on all settings?
    I've just been quoted £50 for a used Heater Blower Motor. Is it worth while getting this or in your opinion is it likely to be something else?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Heater motor/fan removal
    By rdl-sri in forum Bodywork & Interior
    Replies: 13
    Last Post: 3rd December 2012, 15:10
  2. Vectra C Heater Fan Removal - How?
    By markf2 in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 7th February 2012, 12:35
  3. Removal of Heater Control Panel
    By Richard Bignell in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 15th July 2010, 17:37
  4. Heater Control Panel Removal
    By ANDY W in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 18th November 2008, 21:34
  5. Heater control surround removal
    By Ste in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 6th December 2005, 11:47

Visitors found this page by searching for:

vectra c heater blower removal

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •