User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Suspect Injector Problem

  1. #1
    Regular Member DAVO's Avatar
    Join Date
    Nov 2007
    Location
    WEST MIDS
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Suspect Injector Problem

    Any body got any quick fix ideas for a kangarooing CDTi 150 Vectra.Vx dealer is saying it's an injector problem and me spanners come up on the dash. I need to drive the car from Brum to Bristol for works do but am a bit scared as it,s also making a heavy tractor like sound.Vx dealer cant help with curtousy car so stumped.Any ideas.Cheers in advance,Chris.

  2. #2
    Regular Member b-e-r-t's Avatar
    Join Date
    Sep 2007
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When you say it has the tractor sound, im guessing its off a cylinder.

    It could be an injector thats givin up the ghost which is easily fixed, if pricey.

    Other hand it could be the injector loom (or one of its connectors).

    I have a problem with the injector connector on my 3rd cylinder (see post i made today) - it is bringing on the spanner light and causing a bit of the kanagrooing - worst when you have very little throttle down.

    When the car is idling, try moving each connector in turn back and forward a bit - just wiggle it. If the car idles properly (even for a short while) while you are fiddling at it, you know its the connection. If not, its probably one of the injectors.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Injector Problem
    By vectra19 in forum General Motoring Chat
    Replies: 2
    Last Post: 8th June 2012, 23:40
  2. 150 injector problem
    By lee640 in forum Engine & Drivetrain
    Replies: 14
    Last Post: 13th January 2012, 21:13
  3. suspect faulty injector 1.9 cdti 150
    By blakester9 in forum Engine & Drivetrain
    Replies: 13
    Last Post: 18th March 2011, 22:17
  4. Suspect Turbo-related Problem
    By phughes64 in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 22nd July 2010, 11:46
  5. 3rd injector problem
    By smurfy in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 14th April 2009, 16:56

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •