User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Vectra 20DTI problem

  1. #1
    New Member
    Join Date
    Nov 2007
    Location
    Belgrade Serbia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra 20DTI problem

    Hi All,

    My opel vectra c 20 dti have a problem with power loss in mid range. Turn on spanner light, and goes into limp mode everytime i go over 70mph.
    Pull over restart the car, and the spanner light goes out. IF I start off again, get to around 70-80 and it goes into limp mode. as anyone got any idea what it could be?
    In service, check all vacuum hoses, check pressure in intercooler, and evrything is ok?

    Looks like a common failing.

    Greetings,

    Mihailo.

  2. #2
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    It might have saved a fault code, if you have a garage that can read them then it might give you some idea, no doubt some one else with the 2.0dti will be able to give you some more help. Mark (gsi3.2) is the man who will be very helpfull.

  3. #3
    Regular Member ulsternush's Avatar
    Join Date
    Oct 2007
    Location
    Norn Iron
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2.0 DTI

    Trim : Design

    Engine : 2.0

    Year : 2004

    Default

    Check out the below link, it's what sorted my problem.

    http://vectra-c.com/forum/showthread.php?t=32953

  4. #4
    Regular Member tonypc1's Avatar
    Join Date
    Jul 2007
    Location
    on the long road to ruin
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i had exactly the same problem. that link will sort it.

  5. #5
    New Member
    Join Date
    Dec 2007
    Location
    banff
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i had ther same problem with mine. i took it to the dealer the cleaned a pipe and it was fine, dont ask me what pipe it was an air pipe maybe

  6. #6
    New Member
    Join Date
    Nov 2007
    Location
    Belgrade Serbia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Finally solve the problem which I have past 6 months

    Finally solve the problem. Change diesel injection fuel pump and everything is OK. This part is most expensive part on my car. Costs are about 2200 eur?!
    Thanks for all help on this forum.

    Greetings from Serbia.

    Mihailo

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. abs vectra 20dti 2001
    By nell1 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 8th October 2011, 17:28
  2. vectra 20dti can some help, give advice
    By harry71 in forum General Chat
    Replies: 0
    Last Post: 2nd March 2011, 00:00
  3. vectra 20dti can some help, give advice
    By harry71 in forum General Chat
    Replies: 0
    Last Post: 1st March 2011, 23:49
  4. can some help,on vectra 20dti car dosnt start.
    By harry71 in forum General Chat
    Replies: 0
    Last Post: 1st March 2011, 23:44
  5. vectra c 20dti non start
    By wunklekex in forum Engine & Drivetrain
    Replies: 2
    Last Post: 15th January 2008, 10:48

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •