User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Help!!!

  1. #1
    Regular Member
    Join Date
    Oct 2007
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help!!!

    Hi guys,

    just service my 2002 52 plate 2.0 dti vectra C and now the car and spanner light is on can this be reset without having to go to vx?

    It came on after i changed the diesel filter............is now in limp mode permanently i have no idea whats up?help!!!

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    1st.. service light...

    sit in the car and press the brake pedal and the button on the speedo down and hold them both down.. now turn the ignition key to posn 2 and keep holding the pedal and button down...after about 30 seconds it will reset....

    Limp mode...do you have a car and spanner light on the dash or is it just sluggish...if it's got the light on then it's got a fault so it will need fixing before it goes off..if it's sluggish then i wonder if there is still air in the fuel or filter... or the seal may be wrongly seated and allowing air in to the filter...the only way to be 100% sure is to get the fault code read...and that needs a codereader that is CANBUS compatible...

  3. #3
    Regular Member
    Join Date
    Oct 2007
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The light is on all the time. could this be that its pulling air into the filter housing (ie. the sensor ontop of the filter is setting the light off???)

  4. #4
    Regular Member
    Join Date
    Oct 2007
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for the reply by the way!

  5. #5
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it could well be the reason why..it would be worth a check,,..

    don't forget to top the filter right up with clean diesel before screwing the lid on..and check the security of the plug on the top..it does seem to be co-incidental...

  6. #6
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by inneedofhelp View Post
    thanks for the reply by the way!
    it's what we're here for..

  7. #7
    Regular Member
    Join Date
    Oct 2007
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    will the light go away once the fault is rectified?

  8. #8
    Regular Member
    Join Date
    Oct 2007
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    or will it still need a reset? i.e. how will i know if ive fixed it?!!!

  9. #9
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the fault light will go out when the problem has been cured..but it will illuminate every time the car is started for the next 25 restarts after the fault is fixed as the car will store the fault code that long.. so if it's not on when the car is running, the fault is cured..


    the service light will only go out if you reset it as detailed above..

  10. #10
    Regular Member
    Join Date
    Oct 2007
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2 View Post
    and check the security of the plug on the top..it does seem to be co-incidental...
    plug on top?
    is there a workshop manual anywhere on the net that you guys download?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •