User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Power Steering Problem

  1. #1
    New Member
    Join Date
    Aug 2007
    Location
    Neath
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Power Steering Problem

    I have had a problem for some time with my Vectra 03 plate 3.0 CDTi and it is slowly getting worse.
    When driving, usually at slow speed, initially the traction control warning light comes on. This is followed within a few seconds by the power steering warning light appearing. At first the power steering seemed fine, but now occasionally the steering does become heavy at very low speeds. The other strange thing that happens each time is that, when the warning lights are on, the direction indicators no longer self cancel. Self cancelling is fine when the warning lights are out.Two visits to a main dealer have resulted in a loose connection in the steering wheel being diagnosed, but this being 'fixed' has not helped. Any ideas?
    Thanks.

  2. #2
    Regular Member BlueRob's Avatar
    Join Date
    Jul 2006
    Location
    Mexico
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Probably needs a trip to the dealers mate, sounds like a faulty CIM module to me, hope you sort it soon

  3. #3
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yep, code reader time..

  4. #4
    New Member
    Join Date
    Aug 2007
    Location
    Neath
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for that. It's what I expected - just hoped I was wrong

  5. #5
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could be worth getting the alternator checked as i heard that the alternator can run extra power to the pump etc hope you get it sorted fella

  6. #6
    Regular Member
    Join Date
    Apr 2006
    Location
    Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Wow, I have the same problem! my 04 has just started to display the traction control light every now and then. And also the Powersteering light, but also my AFL's work intermittenly?

    What was you resolution?

    Thanks

  7. #7
    Regular Member Maddog1974's Avatar
    Join Date
    Jul 2006
    Location
    Colchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Both sound like the alternator to me as the power steering stops when they are not charging and also other systems detect low voltage so bring on warning lights.

  8. #8
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cim or steering angle sensors
    Now I need a turbo to keep up!

  9. #9
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    I started to have this problem, so looked into replacing the cim in the steering column myself. Think it was £250 +vat just for the cim module. You will also need two tech 2 session's at about £50 a pop. Although the first one is just to reset the fault I think so a simple battery off for 15 mins should sort that. I believe the cim also houses the steering angle sensors hence t/c and power steering lights. Anyway, the fault seams to have disappeared, so it might have just been a lose plug.

  10. #10
    VIP-Member GSiFan's Avatar
    Join Date
    Nov 2006
    Location
    Houghton Regis, Bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra GSi 3.2 V6

    Trim : GSi

    Engine : Z32SE

    Year : 2003

    Mileage : 212,060

    Default

    What is this "CIM" module and where can I find it? I am having these self same problems.

    Cheers.

    Paul

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power steering problem
    By Danwells72 in forum Vectra C / Signum Troubleshooting
    Replies: 15
    Last Post: 9th October 2012, 16:25
  2. On Going power steering problem
    By gazspeight in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 29th November 2011, 18:18
  3. power steering problem
    By mr.d in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 9th August 2011, 22:33
  4. Power Steering problem
    By delete1 in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 3rd January 2008, 20:41
  5. Power Steering problem
    By H11LGX in forum Suspension, Wheels & Brakes
    Replies: 8
    Last Post: 22nd March 2006, 01:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •