User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: loss of speedo, radio, dash ,etc

  1. #1
    New Member
    Join Date
    Oct 2007
    Location
    aberdeen
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default loss of speedo, radio, dash ,etc

    Hi
    Can anyone help. When driving, randomly i lose all lights and instruments and radio, speedo, revs die, no indiacators,etc, but car still runs. This can be sorted by turning off ignition and turn back on again.

    Any ideas

    Cheers

  2. #2
    Regular Member Karl's Avatar
    Join Date
    Apr 2007
    Location
    Sunderland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    loose connection behind the instrument binnacle. Happened to a few of our works' cars. Just take the binnacle out and reseat, or if its in warranty, take it back

  3. #3
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    or also commonly, failure of the CIM module will also upset the operation of those systems as well..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pic request:- led dash/speedo conversion pics
    By taffy bhoy in forum Styling
    Replies: 28
    Last Post: 16th March 2011, 12:13
  2. Replies: 2
    Last Post: 18th December 2010, 20:23
  3. Loss or Radio Reception after installing amps!
    By jrwilshire2003 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 23rd June 2010, 00:42
  4. 3rd Party Radio Causing Dash Fault?
    By akulla in forum Troubleshooting
    Replies: 8
    Last Post: 3rd July 2008, 23:37
  5. Whats the colour of Dash trim for Radio Mount
    By 67688c in forum Bodywork & Interior
    Replies: 0
    Last Post: 25th May 2008, 12:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •