User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: fixed stuck indicator

  1. #1
    Regular Member
    Join Date
    Feb 2007
    Location
    North west
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default fixed stuck indicator

    Been on nights this week, when I got up today wife had left car at work and walked home (an hours walk) rather than ring me and wake me up ! Her car indicators on the drivers side had stuck on - even when she took the keys out. On solid not flashing, by the time she finished work battery was 100 % flat.

    I jump started it after disconnecting the front & rear indicator wires, side repeater was stuck on. Got it home and started to look at things.

    First hunt the fuse box - She drives a w reg astra - its drivers side behind small storage recess if you ever need it. I tried removing each relay one at a time till repeater went out. Once I found the part I rang VX dealer - and parts was closing at 5pm, no chance of making it in time so I tried a local motor factors.

    Guy there didnt have anything suitable but said normally with a stuck relay give it a couple of taps on a hard surface to free it and re fit it.

    Tried it and it worked. Still need to pick up a new relay - but no urgency now as all working fine.

    Hope this helps someone else at some point. If we had no idea I would have called a garage and got car towed in as it was dead - you can guess the bill would be over £100.

  2. #2
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    buy a new vx flasher relay as they are modeified .....they did have a few problems with them !!

  3. #3
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Nice one! It's always a good feeling to diagnose a problem.

    Did something similar on my neighbour's son's Honda Civic. His car wouldn't start but was turning over. Quick look at the fuel lines/injectors deduced no fuel was coming through. Next thought was fuel pump, no voltage was coming through to the pump so pump may have been fine and a dodgy relay. Tested the relay - feeding 12v across different pairs of the relay contacts - to see if the relay was fine (thankfully he had a Haynes manual that gave that sequence of contacts to bridge) and relay was showing as fine, which didn't leave anything else to check, so put it all back in and turned on ignition and the car started first time! I guess the relay had just got stuck and the bridging of the contacts, which activated each switch, had freed whichever one was stuck.

    He was dead chuffed as otherwise he'd have taken it to a dealer/mechanic and paid ££££ for them to diagnose it - and I was kinda pleased with myself for sussing it out too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Jim Fixed it for this lad
    By Ben50n in forum Comedy & Humour
    Replies: 2
    Last Post: 3rd November 2012, 18:14
  2. Left indicator flashing fast, front indicator not working
    By Hummelshøj in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 25th June 2012, 21:13
  3. Swirl Flap Stuck or Not Stuck ??
    By nibblitz in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 3rd November 2010, 17:57
  4. Still not fixed
    By AndrewTi in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 21st June 2006, 22:08
  5. looks like I've just fixed it.
    By AndrewTi in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 11th June 2006, 14:48

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •