User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Ventilation/Climate Control Problem

  1. #1
    Regular Member
    Join Date
    Jul 2007
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Ventilation/Climate Control Problem

    The centre "knob" which controls the menu select (ie up and down movement) on display screen seems to be faulty, in that whenb i get to the air distrubution/air conditioning select screen the rotational movment and push to select charateristic of the knob doesnt seem to function.

    When in the outermost mode (ie. front screen display) the rotational movment adjusts the airflow rate perfectly and the push/select takes me into the menu mode no problem!

    Anyone any idea what may be causing this???

    The "feel" of the knob (flame suit on for the sarcasm!!!) seems to be a little rougher than the heating controls on each side???


    Cheers in advance for any help.

    Al

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    moved to the relevant section for you matey..

    The short answer is you need a new switch panel.. it connect to nothing apart from the cars wiring harness as the air control is all done with servo motors...

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It is a bit more "lumpy" on the centre control knob. Mine did this, but mine also would not control the air fan speed correctly. I had a new unit fitted in the end.
    Now I need a turbo to keep up!

  4. #4
    Regular Member
    Join Date
    Jul 2007
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Sig View Post
    It is a bit more "lumpy" on the centre control knob. Mine did this, but mine also would not control the air fan speed correctly. I had a new unit fitted in the end.
    any ideas how much this cost to replace? car is 6 mths out of warranty FFS!!!

  5. #5
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






  6. #6
    Regular Member Flaninacupboard's Avatar
    Join Date
    Oct 2006
    Location
    Wellingborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    think he has ECC from the description. sounds like maybe a tech2 can fix it if the control for fan speed is working but not once your in distribution control.

  7. #7
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry I have no idea, it was covered under the Net Q so I never saw a bill
    Now I need a turbo to keep up!

  8. #8
    Regular Member
    Join Date
    Jul 2007
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Flaninacupboard View Post
    think he has ECC from the description. sounds like maybe a tech2 can fix it if the control for fan speed is working but not once your in distribution control.
    Yes, i have the Climate Control Option so the fleabay options above wouldnt do. (but cheers anyway matey)

    Seems to be working fine again. Perhaps "reset" itself once ignition was switched off? would this be a likely fix??

  9. #9
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    It might has rest it,s self. People has mentioned that they has no "speedo dials" moving, but on switching the ignition off and on again they worked, keep an eye on it for a while it might be ok now, finger,s crossed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Climate control problem help!
    By CallumHill in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 18th December 2012, 23:20
  2. Climate control problem
    By CallumHill in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 11th December 2012, 23:58
  3. Climate control problem
    By POOL MAN in forum Vectra C / Signum Troubleshooting
    Replies: 15
    Last Post: 11th June 2009, 09:00
  4. Another climate control problem
    By 24vElite in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 8th May 2008, 21:08
  5. Climate Control problem
    By bnam in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 17th July 2007, 14:09

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •