User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: vectra b question

  1. #1
    Regular Member gizmo10119's Avatar
    Join Date
    Jul 2005
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra b question

    i have just sold the mrs's 307 sw and picked up a nice s reg vectra cd auto estate, last owner 5 years, fsh and 106k on the clock

    on the test drive it was fine, nice and smooth, so i hand over 800 in notes and bu99er off home with it

    after a couple of days driving the em light pops on, i have shorted the diagnostic plug to get the em light to flash the code up which was 0340 camshaft sensor.

    my question is would a faulty camshaft sensor cause the car to stall at motorway speed while in the fast lane? (i have cleaned the icv out as it was hunting and it cured it)

    im a little cautious about letting my wife and 2 kiddies out in it, its booked in on thursday in the garage, i hope that a camshaft sensor will cure it, just wondered what you guys think?

    Thanks

  2. #2
    Regular Member The-Bandit's Avatar
    Join Date
    Mar 2007
    Location
    snake hunting
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had one of these and the same problem i reckon, it did go in and have both the crank and cam sensors changed and it was fine after then.

    Hope this helps but keep an eye out for Mark (3.2gsi) posting, hes pretty good when it comes to diagnostics.

  3. #3
    Regular Member gizmo10119's Avatar
    Join Date
    Jul 2005
    Location
    Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks ninja, you just worry about putting your wife and kids in it when you dont really trust the car!

  4. #4
    Regular Member Ridgerider's Avatar
    Join Date
    Feb 2007
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had that light come up on my B and they just changed the sensor...seems like they build the engine better than the sensors.

  5. #5
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I agree, ECOTEC engines suffer from camshaft and crankshaft sensor failures quite often
    My own SRi140 suffered a camshaft sensor failure at about 50K miles, then a crankshaft sensor failure a few weeks later
    When the camshaft sensor next failed I paid for the crankshaft sensor to be replaced at the same time

    The engine will happily work with a failed camshaft sensor, the EMS light appearing from time to time
    However, a failed crankshaft sensor will normally put the engine into safe mode

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Not a Vectra question.......
    By Paulwr in forum Engine & Drivetrain
    Replies: 2
    Last Post: 12th May 2012, 19:53
  2. Vectra b - w/b question
    By tosh23 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 25th April 2011, 05:03
  3. Vectra C Question
    By lee brown in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 29th July 2010, 22:59
  4. Vectra DAB question ?
    By brickit in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 29th July 2009, 21:18
  5. Sorry question about vectra B
    By stubopvectra in forum General Chat
    Replies: 2
    Last Post: 18th July 2009, 09:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •