User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Esp+ and Power steering light

  1. #1
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Esp+ and Power steering light

    I had the Esp+ (tc) and Power steering light come on this morning. Its the second time in about a month or so. I still had power steering so i'm guessing its more of an ESP+ type error?

    Anyone have any ideas on its possible cause?
    Now I need a turbo to keep up!

  2. #2
    Regular Member sig63's Avatar
    Join Date
    Aug 2006
    Location
    Belgium
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Insignia

    Trim : Cosmo

    Engine : 2.0 CDTI

    Year : 2011

    Default

    Could it be that TC or ESP were active or was it longer?

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No they were not active. I was slowly reversing into a parking space. Also they came on with the power steering yellow icon in the display
    Now I need a turbo to keep up!

  4. #4
    Regular Member
    Join Date
    Oct 2005
    Location
    Melbourne, Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like a fault with the steering angle sensor - both the EHPS and ESP systems use the steering angle.

  5. #5
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thats what I thought tbh. Any idea'info on these sensors? are they available seperately??
    Now I need a turbo to keep up!

  6. #6
    Regular Member
    Join Date
    Mar 2007
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This happen to me as well.... but it disappeared after while... I think it depends on the angle of the road/drive way etc... as it happened only on a particular parking lot when I reversed out...

  7. #7
    Regular Member
    Join Date
    Oct 2005
    Location
    Melbourne, Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Sig View Post
    Thats what I thought tbh. Any idea'info on these sensors? are they available seperately??
    Not sure. I think it's part of the CIM, in which case you'd probably have to replace the whole module

  8. #8
    Regular Member marcdale's Avatar
    Join Date
    May 2006
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had this happen a couple of times. When I looked at it I disconnected the battery earth, then I removed the earth straps on the engine block and clenaed them up, on the V6 there is one at the front, one at the back and I think there is one next to ECU's above the gear box. I then checked the fuse inside the battery tray. NOT inside the fuse box, as your stood at the front of the car with the battery in front of you, inside the battery box on the left hand side of the battery at the far end. It's a single fuse with a think red feed going to it. one of the nuts had come loose, and this feed is for your power steering pump.

    I was getting power steering warning lights, occasionally I would loose power steering too, and very occasionally I would get the ESP light come on all the time.

  9. #9
    Regular Member Steel's Avatar
    Join Date
    Feb 2008
    Location
    Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : Z19DTH

    Year : 2005

    Default

    My power steering warning light cam on once on a very very cold morning and I had no power steering. Switched it off and back on again and it reset and has been fine ever since.

  10. #10
    Regular Member
    Join Date
    Jul 2008
    Location
    scunthorpe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    my 2.2 direct started doing this, can park it up ok but when go back to it and start up the tc and ps warning lights are on and have no power steering, turn engine off and back on and is ok, is this the sensor and is it worth having it checked over

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 18th August 2012, 08:58
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. Steering wheel light & loss of power steering
    By the_wave_rider in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 3rd August 2012, 14:09
  4. Steering wheel warning light , no power steering!
    By Domchapp in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 23rd July 2012, 22:11
  5. PLEEEEASE HELP - traction control light/power steering light on!!!
    By holdenvectra in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 28th June 2010, 23:39

Visitors found this page by searching for:

astra j esp light on fixed under warranty

what will cause the esp light to stop on a vectra c 2.2

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •