User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Steering Wheel symbol warning lamp

  1. #1
    New Member
    Join Date
    Oct 2007
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Steering Wheel symbol warning lamp

    Can anyone help please? An orange Symbol of a steering wheel and a"!" has come on and stays on. Also the instruments all stopped working for a while, the instruments have come on again but the warning lamp is on all the time! The Goshawk

  2. #2
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sounds like your fluid could be low? have you still got pas

  3. #3
    New Member
    Join Date
    Oct 2007
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I will check later and let you know, thanks. The Goshawk

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Its a fault in the power steering. No idea what though. Mine came on today too!
    Now I need a turbo to keep up!

  5. #5
    Regular Member BlueRob's Avatar
    Join Date
    Jul 2006
    Location
    Mexico
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I don`t think it`s the fluid level...it`s more related IMO to his dials dropping, issue stated on several post around here...
    http://forum.vectra-c.com/showthread...dials+dropping

  6. #6
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sounds like the CIM module to me..

  7. #7
    Regular Member mark1319's Avatar
    Join Date
    Apr 2007
    Location
    Tyneside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2 View Post
    sounds like the CIM module to me..
    Is that not a bit of a pricy failure? IIRC

  8. #8
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    around £300 inc programming if it is proven to be the fault ( which i strongly suspect it is..)..

  9. #9
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2 View Post
    around £300 inc programming if it is proven to be the fault ( which i strongly suspect it is..)..
    Could mine also be this? http://forum.vectra-c.com/showthread...d=1#post392649
    Now I need a turbo to keep up!

  10. #10
    Regular Member
    Join Date
    Aug 2007
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Sig View Post
    Its a fault in the power steering. No idea what though. Mine came on today too!
    Mine came on today too! No other faults or lights on the dash. Went to the dealers and whilst there the Power steering packed up, but the light went out. As yet they are still trying to work out what is wrong.

    http://forum.vectra-c.com/showthread.php?t=31856

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Steering wheel warning light , no power steering!
    By Domchapp in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 23rd July 2012, 22:11
  2. Steering Wheel Fault Symbol ON !!
    By Bobarache in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 30th January 2011, 09:37
  3. Steering wheel warning light
    By ColinB in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 8th February 2010, 21:20
  4. Intermittent battery and steering warning lamp
    By Rapier in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 3rd October 2009, 18:15
  5. Replies: 7
    Last Post: 22nd December 2006, 23:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •