User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Cruise control failure, Engine light

  1. #1
    Regular Member
    Join Date
    Oct 2005
    Location
    Melbourne, Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Question Cruise control failure, Engine light

    Hi everyone,

    I've had a recurring niggle with my cruise control. The problem is that it won't engage, but then several minutes later it works as if nothing was ever wrong.

    Here's what I've done so far:
    1. Took it to dealer, a fault code had been logged. They replaced the CIM module and stalk.
    2. Same fault again, this time dealer reported no fault diagnosable. Dealer produced a service document pointing out that the brake must be activated at least once after the ignition is activated before cruise control can be activated. (Safety feature I guess). This is not documented in the manual, but it also doesn't explain my problem, since I'm certain I'd used the brakes before trying to use the cruise control.
    3. Engine/immobiliser warning light randomly coming on for several seconds at a time. No apparent effect on driveability or ability to start the car. Now the spanner comes up for a few seconds each time the car is started. Took the car to Holden who scratched their heads, saying they couldn't tell why the light was coming on, but they "reset everything". They claim that no fault codes were stored, but I find this a bit implausible. Surely the engine ECU wouldn't be displaying warning lights with no fault codes to back them up?
    4. The spanner icon's coming on again now. It's booked in at Holden again tomorrow.
    I'm not sure whether the spanner icon and my cruise control problems are related or not, but it does seem to be a bit of a co-incidence. Does anyone have any bright ideas on what might be going on? I'm not very optimistic that this dealer is going to be able to diagnose/fix this problem tomorrow...

  2. #2
    Regular Member Damian's Avatar
    Join Date
    Jun 2005
    Location
    Market Drayton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had a problem in my last Vectra C with the cruise control not engaging, and the way to resolve was to put my foot under the clutch and brake pedal and ensure they were all the way up, then the cruise control would engage.

    Because as I am sure you are aware pressing the clutch or brake disengages it. It wouldn't explain your dash light that is coming on, but might explain the intermittant fault with the cruise control and why the dealer can't resolve it

    Damian

  3. #3
    Regular Member
    Join Date
    Oct 2005
    Location
    Melbourne, Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Damian
    I had a problem in my last Vectra C with the cruise control not engaging, and the way to resolve was to put my foot under the clutch and brake pedal and ensure they were all the way up, then the cruise control would engage.

    Because as I am sure you are aware pressing the clutch or brake disengages it. It wouldn't explain your dash light that is coming on, but might explain the intermittant fault with the cruise control and why the dealer can't resolve it

    Damian
    Thanks @Damian.

    If (when?) it happens again I'll give that a try. I tried pressing both pedals but I never thought of lifting them. The brake switch is nice and easy to diagnose, since you can just check the brake lights. The clutch switch is a bit trickier since AFAIK nothing else but the cruise control uses the clutch switch.

  4. #4
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Damian
    I had a problem in my last Vectra C with the cruise control not engaging, and the way to resolve was to put my foot under the clutch and brake pedal and ensure they were all the way up, then the cruise control would engage.

    Because as I am sure you are aware pressing the clutch or brake disengages it. It wouldn't explain your dash light that is coming on, but might explain the intermittant fault with the cruise control and why the dealer can't resolve it

    Damian
    That's exactly what I did with mine. It only takes you to barely rest your foot on the brake/clutch pedal and it knocks the CC off, so with that in mind I pulled tyhe pedals up with my foot, tried again and it worked fine. That was about 6 months ago and I have had no bother since.
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

  5. #5
    Regular Member
    Join Date
    Nov 2005
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Smile clutch pedal fault

    there is a known fault with the vectra C and Signum clutch pedal return spring. the spring breaks and the fault you describe is a common complaint from drivers. Originally Vauxhall replaced the complete pedal box assembly which meant removing the dash and some of the interior. They came up with a feild remedy which involves fitting a over centre spring which sorts the problem. If their is movement of about half an inch freeplay in the clutch pedal go and see your dealer and ask them to carry out the rework.

  6. #6
    Regular Member
    Join Date
    Oct 2005
    Location
    Melbourne, Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by james.stoogies
    there is a known fault with the vectra C and Signum clutch pedal return spring. the spring breaks and the fault you describe is a common complaint from drivers. Originally Vauxhall replaced the complete pedal box assembly which meant removing the dash and some of the interior. They came up with a feild remedy which involves fitting a over centre spring which sorts the problem. If their is movement of about half an inch freeplay in the clutch pedal go and see your dealer and ask them to carry out the rework.
    Thanks @james.stoogies, I'll have to check that out.

    The spanner light was apparently a history code, something to do with "frist stage radiator fan" or something like that. Doesn't sound like it's related to cruise control. Perhaps I have two problems...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cruise control Cockpit light
    By Betus in forum Bodywork & Interior
    Replies: 8
    Last Post: 20th September 2011, 01:18
  2. Cruise Control dashboard light not working
    By Weaselbert in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 7th March 2011, 15:30
  3. Activate cruise control and low oil warning light comes on??!!!
    By RSV_Ecosse in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th April 2010, 00:16
  4. Cruise control and engine temp issues
    By zerocool in forum Engine & Drivetrain
    Replies: 3
    Last Post: 3rd February 2009, 02:01
  5. Cruise control dashboard light
    By superstuper in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 8th September 2008, 11:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •