User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Sick Signum 2.2 Direct (Fault Codes)

  1. #1
    New Member
    Join Date
    Jun 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Sick Signum 2.2 Direct (Fault Codes)

    Hi Everyone. I hope someone out there can give me a bit of decent advice re my sick Signum. I'll try to make a long story as short as poss. The car has had loads of problems over the last few months starting with poor cold starting, then engine going into limp mode intermittently. I had it into the local stealers who diagnosed a faulty high pressure fuel pump and pressure regulator. Before I had that fixed, the water pump went which cost me just under £1500.00 to get replaced (the job grew after they had got it into their workshop). When I got the car back, the previous faults had disappeared even though they did not replace the pump or regulator although the cold starting was still a problem. A short while later, it developed a constant problem where it goes into limp mode. Everytime I take it to the stealers, they want to charge me for "diagnostic checks" which never seem to diagnose the problem and they just keep wanting to replace parts until the problem is solved. I have now got myself a code reader and the main codes that keep appearing are P0301 (cylinder 1 misfire) this is the one that seems to cause the limp mode and comes up all the time. P0303 happens occasionally and the one that is baffling me is P1666 which now comes up quite regularly. I cannot find any info to what Vauxhalls definition of this code is. Various "knowledgable" people have informed me that the coil pack needs changing, the ect sensor needs changing and a list of other parts that it too long to go into. I don't mind changing parts if they are faulty, but at this rate I'm going to be bankrupt changing parts that do not cure the problems before I have a car that is driveable. Any help would be greatly appreciated. Here's hoping.

  2. #2
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI NAV XP

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 72K

    Default

    P0166 - Heated Oxygen Sensor (HO2S) Circuit Bank 2 Sensor 3 No Activity Detected

  3. #3
    New Member
    Join Date
    Jun 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for that, but is P0166 the same as P1666? If so, Where is the sensor and is there a way of testing it?

    I really do need to get up to date with the mechanics of modern cars.

    Thanks again

  4. #4
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI NAV XP

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 72K

    Default

    Quote Originally Posted by kaston View Post
    Thanks for that, but is P0166 the same as P1666? If so, Where is the sensor and is there a way of testing it?

    I really do need to get up to date with the mechanics of modern cars.

    Thanks again
    List of codes in this

    Unfortunately I only know where the engine is. Surely someone will tell you where your sensor is. It may be in front of the engine block IIRC from a previous thread on here.
    Last edited by john_k_sri; 13th September 2007 at 10:00. Reason: Additions

  5. #5
    Regular Member
    Join Date
    Aug 2006
    Location
    Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Fiat

    Trim : Panda 100HP

    Engine : 1.4

    Year : 08

    Default

    Isn't a oxygen sensor in the exhaust?,try looking on the manifold or downpipe.I think testing it is beyond a home mechanic and substitution is the answer.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. my poor 3.0 sick again..my fault no doubt
    By Guss in forum Y & Z30DT Specific
    Replies: 29
    Last Post: 2nd June 2012, 15:12
  2. 2.2 direct petrol 05. Fault codes
    By mani2002uk in forum Engine & Drivetrain
    Replies: 34
    Last Post: 2nd May 2012, 15:35
  3. Replies: 6
    Last Post: 26th March 2012, 16:42
  4. 2006 Signum 2.2 engine fault codes! Help please :)
    By t13con in forum Engine & Drivetrain
    Replies: 5
    Last Post: 16th January 2011, 16:39
  5. Signum 2.0 dti fault codes
    By Babycake in forum Engine & Drivetrain
    Replies: 4
    Last Post: 7th April 2010, 11:25

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •