User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: oxygen sensor probs?

  1. #1
    Regular Member
    Join Date
    Aug 2007
    Location
    Oop north in rainy Ripon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default oxygen sensor probs?

    Hi Guys.
    The old Vectra c 1800 is giving us some grief again.Twice this month the emissions light has come on for about 30 miles then mysteriously gone out.S'pose its the Oxygen sensor or summat but I'm not taking it down to the local Vauxhall rip-off-merchant,er Vauxhall dealer.Sounds like the sensor maybe needs cleaning at a guess, rather than the statutory nicely priced replacement remedy which normally occurs at these really customer friendly establishments.What's the chance of Redex or summat cleaning it off,or am I gonna have to get my hands mucky and physically clean it off? Cheers.

  2. #2
    Regular Member
    Join Date
    Aug 2007
    Location
    Oop north in rainy Ripon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy nobody know this one?

    No ideas then?

  3. #3
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i wouldn't touch it without getting the codes read to find out why the emmissions light is coming on.. just guessing is where it starts to cost money replacing bits whilly-nilly..

    and no, redex won't clean the sensor..replacement only with a new part is the only cure thats 100% effective..

  4. #4
    Ex-Staff Full Member Ian T's Avatar
    Join Date
    Jan 2006
    Location
    Skynet HQ EMEC#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just to give you an idea how oxygen sensor can play up - my 1.8 had problems as follows:

    I had a powerflow full system fitted, great job but 2 days later, engine management light came on. No problem with engine running though.
    Got very helpful dealer (Marehay Vauxhall, Ripley) to check fault.

    They found a fault logged for 2nd oxy sensor (there is one before cat & after cat) but it wasn't an open fault . Codes cleared but 2 days later same thing again.

    Again went in, checked & tested sensor rather than just throwing a new one in, seemed ok

    Again next day same thing, so sensor changed, been ok since.

    Problem may have been caused by powerflow agent having to install oxy sensor into new system & disturbing it.
    Last edited by Ian T; 5th September 2007 at 08:44.

  5. #5
    Regular Member
    Join Date
    Aug 2007
    Location
    Oop north in rainy Ripon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for your ideas lads.

    the barbelman

  6. #6
    Regular Member ryan.d's Avatar
    Join Date
    Sep 2007
    Location
    Driffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Ian T View Post
    Just to give you an idea how oxygen sensor can play up - my 1.8 had problems as follows:

    I had a powerflow full system fitted, great job but 2 days later, engine management light came on. No problem with engine running though.
    Got very helpful dealer (Marehay Vauxhall, Ripley) to check fault.

    They found a fault logged for 2nd oxy sensor (there is one before cat & after cat) but it wasn't an open fault . Codes cleared but 2 days later same thing again.

    Again went in, checked & tested sensor rather than just throwing a new one in, seemed ok

    Again next day same thing, so sensor changed, been ok since.

    Problem may have been caused by powerflow agent having to install oxy sensor into new system & disturbing it.

    Ian, How much was it to fix?
    Just had mine diagnosed as a faulty o2 sensor, vx quoted £129 fitted.
    Ta

  7. #7
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    Quote Originally Posted by ryan.d View Post
    Ian, How much was it to fix?
    Just had mine diagnosed as a faulty o2 sensor, vx quoted £129 fitted.
    Ta
    Sounds about right for a dealer. you will be paying the best part of £100 for the sensor, then there is the fitting charge. If I was sure it was the sensor I would fit it myself.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lambda / Oxygen Sensor
    By R-man in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 20th August 2012, 21:13
  2. oxygen sensor
    By Richard.roberts in forum Engine & Drivetrain
    Replies: 3
    Last Post: 2nd December 2011, 23:25
  3. Oxygen sensor!!!!
    By darrenmac in forum Engine & Drivetrain
    Replies: 2
    Last Post: 3rd August 2011, 16:53
  4. Help re Oxygen sensor for Z32 SE V6
    By the-converter in forum Engine & Drivetrain
    Replies: 6
    Last Post: 29th September 2009, 15:31
  5. oxygen sensor
    By pipamish in forum Engine & Drivetrain
    Replies: 5
    Last Post: 20th June 2008, 20:43

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •