User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: turbo lag

  1. #1
    Regular Member chinky's Avatar
    Join Date
    Jul 2007
    Location
    midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default turbo lag

    ive a vec 1.9 120 no turbo lag wse the wife has a sig 1.9 150 very litte turbo lag though i drove another sig 150 the other day with loads of lag. is it common to get some with none and some with loads of lag btw all cars are less than 2years and under 15000 miles

  2. #2
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The 1.9 150 does seem to suffer from lag badly given owners comments - not sure why your wife's doesn't. Maybe she's just lucky!

  3. #3
    Ex Vec-C Admin Stevel's Avatar
    Join Date
    Nov 2006
    Location
    Chester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The power band is very narrow. If you get the turbo spinning there is next to no lag. All three of the 150 cdtis I've driven have been pretty much identical.

  4. #4
    Regular Member chinky's Avatar
    Join Date
    Jul 2007
    Location
    midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yea i thought the 150s did suffer from this so the mrs must b lucky

  5. #5
    Regular Member John35's Avatar
    Join Date
    Jun 2007
    Location
    in a white box
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i don't notice any noticeable lag on my 120 compared to a BMW 530D (single turbo) although the twin turbo is that not much better IMO..

    BMW is faster though...........

  6. #6
    Regular Member Ian S100's Avatar
    Join Date
    Mar 2007
    Location
    Southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Stick a tuning box on the 150, give it some stick & you can feel it torque steer when the power kicks in

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 19
    Last Post: 6th September 2014, 13:54
  2. Turbo Technics Hybrid turbo details.
    By nutron in forum Diesel Engine related
    Replies: 13
    Last Post: 28th February 2011, 22:57
  3. TD04L14T turbo for Z20NET (2.0 turbo)
    By Caveman_nige in forum Parts for sale
    Replies: 3
    Last Post: 10th October 2010, 13:23
  4. Turbo Help
    By CDTi-SRi-Matt in forum Engine & Drivetrain
    Replies: 5
    Last Post: 12th February 2010, 11:42
  5. is it possible to change 2.0 dti turbo to 2.2dti turbo
    By EURO G in forum Engine & Drivetrain
    Replies: 17
    Last Post: 22nd October 2008, 07:35

Visitors found this page by searching for:

lagwse band

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •