User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Power Steering

  1. #1
    Regular Member
    Join Date
    Jun 2005
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Power Steering

    Here's a strange one?

    Got in the car a week gone Sunday after it being parked up for a short while at the local shops, put the ignition on, all fine, start up, all fine then go to pull away and realise I have no power steering at all and then the yellow warning sign comes up on the dash board (steering wheel with exclamation mark on). Oh no I thinks. So switch off and pop the bonnet, half expecting to see a pool of fliud under the car, but nothing, power steering fliud level was normal . So I get back in thinking where is the nearest Vx garage, start up and everything fine again and has been for over a week. Never had any reason to think I could have a problem beforehand.......Hicup in the software or what

  2. #2
    Regular Member ion's Avatar
    Join Date
    Aug 2005
    Location
    walsall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This happened to me once as well a few months ago.

    I turned the car off, restarted & it was fine. It has never repeated either.

    I think the power steering is electric on the C's?

    Maybe the computer just didn't "boot up" right & sent an error switching off the steering?

    If it happens again, get it checked, otherwise I think its a one off.

  3. #3
    Regular Member
    Join Date
    Jun 2005
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    How did you check the fluid level, can barely see my reservoir cos its tucked in behind and below the headlight .

  4. #4
    On a Sabbatical
    Join Date
    Jun 2005
    Location
    Failsworth, Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by ion
    This happened to me once as well a few months ago.

    I turned the car off, restarted & it was fine. It has never repeated either.

    I think the power steering is electric on the C's?

    Maybe the computer just didn't "boot up" right & sent an error switching off the steering?

    If it happens again, get it checked, otherwise I think its a one off.
    Wise words! Good advice.

  5. #5
    Regular Member MLC's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Had exactly the same thing happen to me once. Turned the car off and back on and all was well. It's never happened again.

  6. #6
    Regular Member Beavis's Avatar
    Join Date
    Jul 2005
    Location
    Blackburn Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by MLC
    Had exactly the same thing happen to me once. Turned the car off and back on and all was well. It's never happened again.
    same here but done it twice in 4months but just switch off on restart all ok

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Power steering pump noise? but no steering problems
    By bennettboy in forum Engine & Drivetrain
    Replies: 2
    Last Post: 2nd November 2012, 21:33
  3. Steering wheel light & loss of power steering
    By the_wave_rider in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 3rd August 2012, 14:09
  4. Steering wheel warning light , no power steering!
    By Domchapp in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 23rd July 2012, 22:11
  5. Power Steering Electrical Power Drain
    By AntB in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 1st November 2007, 16:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •