User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Boost Pressure Sensor

  1. #1
    Regular Member vectravirg's Avatar
    Join Date
    Sep 2006
    Location
    Bolton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Boost Pressure Sensor

    Following on from this thread

    http://www.vectra-c.com/forum/showthread.php?t=26070

    And me taking the Vectra into the dealers today while in limp mode they have said it definately requires a new Boost Pressure Sensor and it's going to cost £185.50 fitted. Part now on order and going in next week to get it sorted.

    Anyone else had to have one replaced?
    Is this price reasonable?
    And what are the chances of this problem problem being related to the tuning box I've had on it?

  2. #2
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I had a new BPS fitted on my 2.0T - have no idea of price as it was under warranty.

    As for being related to the box, shouldn't think so as all the box is doing is increasing fuel pressure at the rail.

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Mine went, I have no idea why!
    Now I need a turbo to keep up!

  4. #4
    Regular Member vectravirg's Avatar
    Join Date
    Sep 2006
    Location
    Bolton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Astrase20 View Post
    Mine went, I have no idea why!
    Just read the old thread again and noticed you mentioned thats what went on yours as well.
    Take it you haven't had any problems since you had the BPS changed?

    All this is making me wary of putting the box back on but I just loved the drive with it on.

    Think I'll be looking into a remap.

  5. #5
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    No problems since although I don't run a box, but as said the box just increases the fuel pressure not the boost pressure. I think willoc - ? on the user name - went as well. He's got a 3.0v6 diesel elite veccy i think.
    Now I need a turbo to keep up!

  6. #6
    Regular Member vectravirg's Avatar
    Join Date
    Sep 2006
    Location
    Bolton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry

    Not Happy. Had the new Pressure Sensor fitted on Tuesday, managed to knock VX down from £185 to £131 after reminding them I'd already spent £200 on (mis)diagnosis.
    Driving home from work tonight 4th gear, put my foot down just over 4000 revs - limp mode.
    Onto them first thing in the morning but its starting to get me down, love the car to bits but its about the 10th problem in as many months.
    Just when you think you've sorted it - you ain't.

  7. #7
    Regular Member
    Join Date
    Oct 2005
    Location
    south yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    this is one of the things i had a problem with amongst many others.the cars now been sold

  8. #8
    Regular Member vxrdaz's Avatar
    Join Date
    Jun 2006
    Location
    dudley
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi all

    On my 3rd boost pressure sensor as of tuesday. Fixed under warranty again.

    Regards

    Daz

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. boost pressure sensor input and output voltage???
    By FLOB in forum Engine & Drivetrain
    Replies: 45
    Last Post: 24th April 2012, 14:58
  2. boost pressure sensor
    By iwtand in forum Engine & Drivetrain
    Replies: 18
    Last Post: 5th February 2012, 20:43
  3. 2.0 dti boost pressure sensor
    By jono m in forum Engine & Drivetrain
    Replies: 2
    Last Post: 3rd January 2011, 12:08
  4. Boost pressure sensor screw thread
    By Godzilla in forum Engine & Drivetrain
    Replies: 4
    Last Post: 5th June 2010, 20:59
  5. boost pressure sensor
    By johnbattams in forum Engine & Drivetrain
    Replies: 12
    Last Post: 26th March 2009, 17:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •