User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Signum 1.8. lacks power,judders and surges!!!

  1. #1
    Regular Member
    Join Date
    Jun 2007
    Location
    derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Question Signum 1.8. lacks power,judders and surges!!!

    First just like to say hi to everyone and yea I know I need to post photo's asap.All in hand. So I'd thought I'd start with a problem or two just to test you out!!!!

    New to VX, Had this Signum 1.8 Elegance for a month. It's 8 months old with 4000 on the clock. It lacks power like it takes for ever to build up and it judders and surges, which is more evident when cold, but ever so slighty that at first you put it down to change of car syndrome. But other people have commented, although, only when asked . The clutch isn't the smothest I've driven and also tends to be erratic, sometimes over revs and engages so slowly like your going up a steeeeep hill!! However I think the Signum is a fantastic car and otherwise drives as should, just need to iron out what I hope is a small problem. Any ideas?

  2. #2
    Regular Member
    Join Date
    Jun 2007
    Location
    derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Oh well, car booked in at Pentagon ,Derby, wednesday. I really wanted some ideas as to what the problem might be before they baffle me with techno talk!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Signum Sluggish low power, Limp mode at high power.
    By Bigg943 in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 6th June 2011, 18:55
  2. Signum Sluggish low power, Limp mode at high power.
    By Bigg943 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 5th June 2011, 11:30
  3. cdti lacks power when cold, & engine light on
    By mr_dog in forum Engine & Drivetrain
    Replies: 2
    Last Post: 8th February 2010, 22:45
  4. Car kangaroos and judders help please...
    By lester8436 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 16th June 2009, 12:42
  5. 314 Set Up Lacks Bite
    By maxcars1 in forum Handling & Braking
    Replies: 23
    Last Post: 22nd October 2008, 18:53

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •