User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Heat exchanger problem

  1. #1
    Regular Member
    Join Date
    Mar 2007
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Smile Heat exchanger problem

    I had my car serviced on Monday, where they flushed out the coolant and topped up with new...

    Anyhow... in three days time the warning sign came on saying that the level of coolant was low....

    so I took it back to the dealers to have the pressure checked..... and only to find out that my heat exchanger was leaking!!! Which will cost me A$500 to fix it...which is about.... 200pounds..

    I had no problems at all before getting it serviced..... any ideas on what could have possibly happened? Or is it simply pure bad luck and timing?

    Also... since I'm not much of a mechanics person so this might sound really stupid..... I had some steam come up when having the heaters on.... and I'm quite scared that it did some damage to the heating system.....

    Can someone please tell me if the heat exchanger problem could have caused any damage to the engine, radiator, heating system etc?

    (got the dealers to check the auto box for any contamination but all was good. Phew!)


    HELP~~~ from Australia...

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it sounds like the flushing disturbed something in the exchanger.....the two are too closely related to be anything less than a coincindence..

    i doubt it did damage the heating system.. not unless they used a pressure filler, but i can't see it would rupture the heater matrix..

    the only possible damage could be if the coolant mixed with the engine oil, so i'd get that checked out..

  3. #3
    Regular Member
    Join Date
    Mar 2007
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for the reply gsi...

    I already paid the money... to the dealer since I'm out of warranty... and also they said that the water pump was leaking or something.. so had to fix that as well... ...

    anyhow.. at the end i ended up paying $1175 AUD which is around 420 pounds... ...

    do you think that I have a case where I can argue that it wasn't purely "bad luck?"...

    If it is a case what should I say to them that actually sounds convincing that it was their fault not me?

    Please~~ help me

  4. #4
    Regular Member
    Join Date
    Mar 2007
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Also, I got them to check the gear box fluid and the engine oil....

    No contamination in the box... and even if it fails i changed them under warranty a year ago and still have 2 year Holden parts warranty on it....

    and also got them to check the engine oil... and no mayonaise or... should I call it chocolate milkshake...

    So everything is cool, and the car's running fine....


    But i'm beginning to fear about the realiability of my veccy......

  5. #5
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    well, the water pump is a known smalltime failing of the Z23SE, it's a carry over design from the old C25XE, and i always change them every time i do a cambelt anyway..as long as the oil isn't contaminated with the coolant water and no is the gearbox then you should be fine again....the vectra is a tough old barge but i can't help but think the coolant flush the did somehow aggrivated something and gave you a problem..

  6. #6
    Regular Member
    Join Date
    Mar 2007
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mark, one question, I noticed that my car started to vibrate a bit on idle... which I don't remember happening on my car befores service...

    does this vibration has anything to do with the heat exchanger, water pump, etc? or is it simply the matter of the idle valve (read a forum about this after searching this site...)

    I'm thinking that it's not much of a big deal... but just something annoying.... or am I wrong?

  7. #7
    Regular Member
    Join Date
    Mar 2007
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Also... forgot to mention... when I turned on the heater or A/C.... the vibration stops... obviously... i guess it's becuase the rpm goes up...

    But the funny thing is... my idle's been always at 550rpm... but only started to pick up the vibrations...

    argh!!! annoying~~~

  8. #8
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it may be that the car is idling too slow now, as if the AC lifting the revs cuts the rattle..this can be lifted by the dealers via tech2..

  9. #9
    Regular Member
    Join Date
    Mar 2007
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers mark

  10. #10
    Regular Member Geoshaw's Avatar
    Join Date
    Mar 2006
    Location
    Armadale (West Lothian)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2 View Post
    well, the water pump is a known smalltime failing of the Z23SE
    Is this a new engine?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Windscreens - Heat absorbing or heat reflecting?
    By Caveman_nige in forum General Motoring Chat
    Replies: 7
    Last Post: 4th February 2013, 22:09
  2. heat pad
    By male 2.2 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 15th October 2012, 15:09
  3. help no heat
    By monty2000 in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 15th October 2009, 21:49
  4. No heat
    By schmuh in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 7th October 2009, 23:36
  5. and then, there was heat !
    By suj786 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 24th November 2005, 17:50

Visitors found this page by searching for:

vectra c heat exchanger

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •