User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Mid Range Power Loss

  1. #1
    Regular Member
    Join Date
    Mar 2007
    Location
    yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Mid Range Power Loss

    My sri 150 has a severe power loss at 3500 - 4000rpm. The engine seems to hesitate as though either one or more plugs missing or engine is chocked. If the accelerator is backed off slightly and presessed repeatedly the engine clears itself to 4000rpm with plume of blue smoke from exhaust and then accelerates away as normal without missfire to max revs.

    Any ideas please what could be causing this huge flat spot which is particularly annoying when travelling at steady 70mph when the engine hunts up and down.

    Had new set of plugs and coil pack recently. Pre-cat removed.

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    blue smoke is burning oil.....which shouldn't be happening..

    does it smoke normally?.. will it do it if the car is stationary?..

    if you remove the plugs is one 'wet' with oil or stained?..

  3. #3
    Regular Member
    Join Date
    Mar 2007
    Location
    yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It smokes on cold start up but not when warm.

  4. #4
    Regular Member robzc's Avatar
    Join Date
    Mar 2007
    Location
    South West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Could this be due to plugs oiling up from leaking valve stems & seals? It's a long shot, but backing off then flooring it would cause any oil in the cylinders to be burnt off - my ancient Astra (1990) had a bit of a problem like this some time ago, but admittedly it was 10 years old and driven hard constantly.

  5. #5
    Regular Member
    Join Date
    Mar 2007
    Location
    yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This could be one possibility. Could it be EGR valve? Engine cuts out occasionally after motorway run when changing down gear but starts on release of clutch with smoke emitted.

  6. #6
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by george View Post
    This could be one possibility. Could it be EGR valve? Engine cuts out occasionally after motorway run when changing down gear but starts on release of clutch with smoke emitted.
    that sounds more like an idle valve fault than an EGR fault..you need to get this properly looked at..

  7. #7
    Regular Member
    Join Date
    Mar 2007
    Location
    yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Can you please explain 'idle valve fault' not heard of this expression.

  8. #8
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it's when the car refuses to rest at idle, as the inertia of the drivetrain is disconnected the engine relies on the idle valve to maintain a minumum rpm as you change between the gears..a failed valve will not allow the engine to run as it will let the rpm drop below a level where the engine will then stall..

  9. #9
    Regular Member
    Join Date
    Mar 2007
    Location
    yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Where is idle valve located?

  10. #10
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    on your 2.2??.. it's in the housing that the air hose from the air filter runs to, before it enters the plastic intake manifold..it's called the intake assy..

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. loss of power
    By iansfocus in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 28th June 2010, 18:01
  3. Power Loss 2.0T
    By gibbon7000 in forum Engine & Drivetrain
    Replies: 14
    Last Post: 30th April 2009, 23:13
  4. loss of power
    By vectra kh in forum Engine & Drivetrain
    Replies: 12
    Last Post: 27th December 2008, 21:41
  5. loss of power
    By m20_swe in forum Engine & Drivetrain
    Replies: 27
    Last Post: 1st June 2007, 13:28

Visitors found this page by searching for:

z22se loss of power

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •