User Tag List

Thanks Thanks:  3
Likes Likes:  4
Results 1 to 10 of 10

Thread: Electrics go off when throttle is pressed

  1. #1
    New Member
    Join Date
    Sep 2015
    Location
    pompey
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9 CDTI

    Year : 2006

    Default Electrics go off when throttle is pressed

    Morning all,

    Vectra C 1.9 Cdti 2005

    Having a strange problem, arriving home from work the other night my electrics cut out, everything, lights dash power steering, engine still l running.
    turned off and restarted, car started again fine, all electrics working again, but as soon as the throttle is pressed everything electrical went off.

    Went out to check the following morning and the battery was dead.
    Tried charging the battery overnight, seems it had, had it.

    New battery installed, car starts fine all electrics now working again, but as soon as the throttle is pressed everything electrical cuts out, the engine continues to run. some of the dash comes back on once revs settle (sometimes).

    Any ideas anyone, i'm stumped...
    Thanks

  2. #2
    Regular Member
    Join Date
    Nov 2013
    Location
    suffolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra 2007

    Trim : sri

    Engine : z18xer

    Year : 2007

    Default

    Check for any loose Earth connection (Where it goes to the Car's body) - or Positive connection, would be my suggestion.
    A tricky one, keep us posted.
    Was the original battery actually faulty?

  3. Thanks mikescort thanked for this post
  4. #3
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Alternator putting out too much voltage maybe?

    Have you checked with a multimeter that you're only getting approx. 14 volts with the engine running? With it revving it shouldn't go above approx. 14.6 volts as the voltage should be regulated.

  5. Thanks mikescort thanked for this post
  6. #4
    New Member
    Join Date
    Sep 2015
    Location
    pompey
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9 CDTI

    Year : 2006

    Default

    Thanks Dave and Bob, I will check the voltage at the battery tonight when the car is running, Just picked up the multimeter from work. Will also check the old battery.
    I have checked for loose connections anywhere i can but not found anything

  7. #5
    New Member
    Join Date
    Sep 2015
    Location
    pompey
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9 CDTI

    Year : 2006

    Default

    Update:
    Went to check voltages last night, new battery is flat, I know suspecting a short somewhere,
    Will charge battery tonight, on Fri/Sat once ready I will pull all fuses and then put them back whilst watching voltage and current draw hoping to find the culprit that way

  8. Likes nikroc liked this post
  9. #6
    Forum Moderator soulman's Avatar
    Join Date
    Sep 2006
    Location
    Essex
    Post Thanks / Like
    Mentioned
    28 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : Astra Twin Top

    Engine : 1.9cdti

    Year : 07

    Mileage : 97000

    Default

    Good Luck ,keep us updated .

  10. Likes mikescort, nikroc liked this post
  11. #7
    Regular Member
    Join Date
    Nov 2013
    Location
    suffolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra 2007

    Trim : sri

    Engine : z18xer

    Year : 2007

    Default

    Quote Originally Posted by mikescort View Post
    Update:
    Went to check voltages last night, new battery is flat, I know suspecting a short somewhere,
    Will charge battery tonight, on Fri/Sat once ready I will pull all fuses and then put them back whilst watching voltage and current draw hoping to find the culprit that way
    Check Glove box or Boot lights are not staying on when closed - I believe an unusual, Alternator fault, can run a battery down, too.

  12. Thanks mikescort thanked for this post
  13. #8
    New Member
    Join Date
    Sep 2015
    Location
    pompey
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9 CDTI

    Year : 2006

    Default

    Update 2,

    Thanks everyone for your help.

    I put multimeter in series set to amps.
    drain of .5A to 2A,
    started pulling fuses, no change in drain current
    Pulled all fuses, reset everything. no drain showing on meter. 12.6V at battery
    out fuses back 1 by 1 hoping to see the drain start, nothing.
    tried the same with relays, still nothing.

    Then I remembered I hadn't checked voltage with car running as there wasn't enough power to start it last time i was looking at it.
    There is 18.4V across the battery when it's running!! (Alternators voltage regulator possibly at fault?)

    New alternator ordered

  14. #9
    Regular Member bibu16v's Avatar
    Join Date
    Oct 2021
    Location
    Timișoara
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SW Elegance II Sapphire Black

    Engine : Z18XER

    Year : 2008

    Mileage : 155k km

    Default

    It seems like a faulty alternator, as suggested caused by voltage regulator at fault.
    Your battery should be checked, overcharging it for a long time could damage it irreversible...but put on the new alternator and you'll find out soon, maybe you & your battery are lucky...

  15. #10
    Regular Member
    Join Date
    Nov 2013
    Location
    suffolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra 2007

    Trim : sri

    Engine : z18xer

    Year : 2007

    Default

    Seems like I'm a good guesser - let us know how you get on, changing the Alternator will probably need a pit or lift.
    Had you previously tried a jump start & got the polarity wrong?
    That will mess up an Alternator.

  16. Likes soulman liked this post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. throttle pedal/ throttle body change
    By xantiaman1 in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 13th May 2018, 19:11
  2. My new pressed plates
    By marc vectra sri in forum Styling
    Replies: 4
    Last Post: 19th August 2013, 09:03
  3. Question about electrics on throttle body
    By jsud2002 in forum Engine & Drivetrain
    Replies: 17
    Last Post: 8th October 2010, 19:41
  4. where to get pressed plates from?
    By Morephun in forum Styling
    Replies: 11
    Last Post: 11th February 2010, 13:44
  5. pressed number plates
    By Morephun in forum Styling
    Replies: 2
    Last Post: 6th May 2009, 20:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •