User Tag List

Thanks Thanks:  1
Likes Likes:  2
Results 1 to 6 of 6

Thread: Glowplug issue

  1. #1
    Regular Member
    Join Date
    Nov 2010
    Location
    Shropshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Ecoflex


    Engine : 2000 diesel

    Year : 2013

    Default Glowplug issue

    I was getting 'service soon' messages and when I scanned for codes it was showing P0672. So I cleared the code, replaced number 2 glowplug and all was fine for a couple of journeys but then the 'service soon' message returned.

    I have rescanned it the only code is P0672 but is showing as historic and status 7F (see screenshot). If I delete the code it tells me it's cleared but it reappears if I rescan. The service soon message reappears after a couple of journeys.

    Does anyone know what this means? Ie, is the glowplug still a problem, what else should I do, or can I ignore it, will the service soon message go away eventually, etc?

  2. #2
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    68 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    Historic... use a proper scanner to wipe the historic faults... not all andriod capable devices actually clear the historic faults... they need to be send a proper erase command rather than a wipe as most andriod apps do.

    Anyway if you want a proper andriod app that actually does remove historical faults, use scanmyopelcan mind you it's not free

  3. Likes heraldsteve liked this post
  4. #3
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Are you sure you replaced the correct glowplug and not No.3?

    Cylinder No.1 is at cambelt end.

    Sorry if that's teaching granny to suck eggs, but people have been known to think No.1 is at flywheel end.

    The "
    service vehicle soon" message will remain until the fault has been rectified, which suggests you haven't got to the bottom of the problem.

  5. Likes heraldsteve liked this post
  6. #4
    Regular Member
    Join Date
    Nov 2010
    Location
    Shropshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Ecoflex


    Engine : 2000 diesel

    Year : 2013

    Default

    Thank you for the tips

  7. #5
    Regular Member
    Join Date
    Nov 2010
    Location
    Shropshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Ecoflex


    Engine : 2000 diesel

    Year : 2013

    Default

    It's definitely number 2 I've replaced. I only get the historic code since I changed it so something has changed. I will try a different app as mentioned above.
    Last edited by heraldsteve; 23rd November 2021 at 15:10.

  8. #6
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by heraldsteve View Post
    It's definitely number 2 I've replaced. I only get the historic code since I changed it so something has changed. I will try a different app as mentioned above.
    The historic code should clear itself from the ECU memory after a certain number of clean starts or "x" amount of days without detecting another fault.

    The fact you're still getting the service vehicle soon message suggests there is still a problem. Historic codes shouldn't put it back on again.

  9. Thanks heraldsteve thanked for this post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. snapped glowplug :-(
    By Tyz in forum Engine & Drivetrain
    Replies: 5
    Last Post: 21st October 2014, 18:49
  2. glowplug resistance
    By tomo610 in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 23rd January 2012, 18:23
  3. Egr & glowplug issues
    By VECTRA HEAD in forum Engine & Drivetrain
    Replies: 0
    Last Post: 6th October 2011, 20:59
  4. glowplug light
    By chris1804 in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 13th October 2009, 13:54
  5. glowplug light
    By bob4 in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 12th October 2009, 20:52

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •