User Tag List

Thanks Thanks:  2
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Problems with power

  1. #1
    New Member
    Join Date
    Sep 2021
    Location
    Lithuania
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Hatchback

    Engine : z19DTH

    Year : 2008

    Default Problems with power

    Hello all, I'm new at this forum. Sorry if my english is not so good but I hope everything will be clear enough

    So I have problems with low power. Driving 1.9cdti 150hp Signum. It feels really sluggish if I floor acceleration pedal from like 1,2k rpm and it rises very slow, after it reaches like 2,2k it feels much more better, I can feel turbo working then, but seems that it's still not right. Some other example is if I drive at ~1,5k rpm and then floor it, it feels much more better.

    So what is already done to the car:
    • DPF removed, mapped out.
    • EGR blanked, mapped out (but only blanked at two sides on EGR, I mean it's not blanked on exhaust manifold side because it's really hard to get there.. but I believe it's not a big deal? Or it could impact such power loss? )
    • Swirl flaps removed.
    • New MAP sensor.
    • New boost control solenoid.
    • Second hand MAF sensor, I took it from a crashed car but it was driving good before, so I guess it's alright..
    • Cleaned injector contacts. Used zip tie on them.. Anyway all contacts looks good and shine, but 3rd injector contact seems really dirty, even after cleaning it, it becomes dirty fast, so I'm not sure should I buy a replacement kit for it.
    • Cleaned throttle body, it was full of oil, but I haven't had any problems with shutting the engine, and as I know throttle body doesn't have anything related to power??
    • Turbo actuator rod seems to move freely enough.
    • Changed all vacuum lines going from vacuum pump to boost control solenoid and turbo.
    • No black smoke or other smoke, just sometimes little blue smoke when starting car in cold morning.
    • No fault codes.


    Currently I'm thinking of looking for splits in pipes but if they were leaking wouldn't I hear whistling or similar sounds when driving? on weekend I can do video of turbo actuator rod movement and also can make a live log when flooring down from 1.2k in third gear if someone could help me read them cause I don't understand them good.

  2. #2
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    hello, go and introduce yourself in the appropiate topic and post up a picture of the car in that topic.

    But to help you out, please put up a video of the car running so we can have a better idea of what is going on, and did you cleanout the intake when you decided to block the egr and remove the swirl flaps? because if you haven't chances are that is the problem.

  3. #3
    New Member
    Join Date
    Sep 2021
    Location
    Lithuania
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Hatchback

    Engine : z19DTH

    Year : 2008

    Default

    Quote Originally Posted by northpole View Post
    hello, go and introduce yourself in the appropiate topic and post up a picture of the car in that topic.

    But to help you out, please put up a video of the car running so we can have a better idea of what is going on, and did you cleanout the intake when you decided to block the egr and remove the swirl flaps? because if you haven't chances are that is the problem.
    Hi, just made an introduction

    Since I haven't removed swirl flaps by myself I don't know if intake was cleaned when doing removal, but I think it should be. What kind of video should I make? Gonna do some live log and turbo actuator arm movement video tomorrow.

  4. #4
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    Just a video of the car running at idle... and yes do a log.

  5. #5
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    ps make a video of you pushing the turbo actuator rod all the way up... this is to determine if the vnt mechanism has full range... the video of the car running should also clearly show the vacuum lines that connect to the various electric operated vacuum valves.

  6. #6
    New Member
    Join Date
    Sep 2021
    Location
    Lithuania
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Hatchback

    Engine : z19DTH

    Year : 2008

    Default

    Quote Originally Posted by northpole View Post
    Just a video of the car running at idle... and yes do a log.
    Some videos and 3rd gear log pedal to floor.



    LOG:
    https://www.dropbox.com/scl/fi/iqukx...68dpy387goxz9y

    Haven't saw that you asked to push actuator rod so I haven't done such video.. But actually I tried to reach it with my hand and I couldn't... very little space there , I wonder should that rod move much when accelerating at idle?
    Also you can hear some whistling sound from turbo when revving at idle. Is it normal?

    I add few more photos.
    I notice that when revving I feel some air coming but can't say from where... But I actually believe is from that flexi pipe which I circled red.

    20210911_172640.jpg
    Could it be a cause of low power? I wanted to blank that exhaust manifold (when I was doing the EGR blank) but I couldn't manage to get there, seems that it needs to remove bumper, radiator... Which is quite big job .

    Also injectors corrections, but probably not much to say about them?
    20210911_181256.jpg

  7. #7
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    Whistling sound from turbo is normal, even more so when the egr is disabled.. but that pipe you are on about might be the problem. For the rest it seems to be oke... including the logs.
    Last edited by northpole; 12th September 2021 at 17:00.

  8. #8
    New Member
    Join Date
    Sep 2021
    Location
    Lithuania
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Hatchback

    Engine : z19DTH

    Year : 2008

    Default

    Quote Originally Posted by northpole View Post
    Whistling sound from turbo is normal, even more so when the egr is disabled.. but that pipe you are on about might be the problem. For the rest it seems to be oke... including the logs.
    Just wondering if it really can affect power on low rev range? But obvious that something is wrong if I can feel air gust coming from somewhere when revving. Now I'm not sure how to blank exhaust manifold cause access is really bad..

  9. #9
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    If you look on youtube there must be a video showing this being done to a similar engined car

  10. #10
    Midlands - Vxr Owning Dick Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Post Thanks / Like
    Mentioned
    318 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    If it was leaking there would be soot all around it and it would be making an awful noise, as for blanking the manifold end of the egr i managed ok without removing the rad pack.

    IMG_1568.jpg
    Last edited by Dog_Book; 14th September 2021 at 18:45.
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 255/300
    Eibachs B8's, fully loaded factory options

    Tech2 & MDI diagnostics + SPS

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems already! No power in 1st/2nd
    By Neds in forum Engine & Drivetrain
    Replies: 6
    Last Post: 6th May 2014, 18:09
  2. power problems
    By DavieVectd120 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 26th January 2011, 17:21
  3. Power problems
    By gibbon7000 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 16th April 2009, 10:28
  4. 150 CDTI Power Problems
    By multi in forum Engine & Drivetrain
    Replies: 6
    Last Post: 12th January 2009, 19:58
  5. Power problems on my 1.9CDti (120)
    By RedLine in forum Engine & Drivetrain
    Replies: 11
    Last Post: 26th July 2008, 22:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •