User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: 07 plate interior light ribbon

  1. #1
    New Member
    Join Date
    Oct 2020
    Location
    Birmingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 1.9

    Year : 07

    Default 07 plate interior light ribbon

    Hi, ... Owned my 07 Vectra since new, unfortunately the rear interior light some how fell out (think with help from my son) the black 'clip' has detached from the ribbon. I've pushed them together and the lights work but can't get them to stay in place (if that makes sense). Any ideas on how to connect the ribbon back to the 'clip' I have looked for a thread on it ... But can't find one. Any help will be appreciated thanks

  2. #2
    Midlands - Vxr Owning Dick Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Post Thanks / Like
    Mentioned
    303 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    And it’s taken 13 years to find the forum, I’m shocked.

    It should clip back in place.
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 255/300
    Eibachs B8's, fully loaded factory options

    Tech2 & MDI diagnostics + SPS

  3. #3
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default

    Theres a little metal clip on 1 side that can fall out (which ive found out the hard way) and if this is missing it wont stay in place

  4. #4
    Regular Member
    Join Date
    Jul 2018
    Location
    Hemel Hempstead
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTi

    Trim : SRI

    Engine : Z19DTH

    Year : 2008

    Default

    This has happend to me as well, but when i pushed the light back in it all went black and the lights went out, I still can't get the interior lights to work, there was burning smell, but this has gone away.

    I have replaced the fuses for the alarm as I keep getting a warning on the screen that it is not working.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. replacing interior light ribbon
    By trucker11 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 4th February 2013, 15:31
  2. rear interior light ribbon
    By baz2003uk in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 21st April 2012, 20:23
  3. Rear Interior Light/no Ribbon
    By BRUCE120 in forum Styling
    Replies: 0
    Last Post: 10th December 2006, 16:38

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •