User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Vectra cdti wont even rev

  1. #1
    New Member
    Join Date
    Oct 2020
    Location
    Doncaster
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 1.9 cdti 150

    Year : 2006

    Default Vectra cdti wont even rev

    Hi all. I have got a 06 vectra cdti 150 sri that has just lost all power within the turn of a key. I got it off the son in law cos he was going to scrap it due to a clutch issue and only 2 weeks mot left on it, it's in good condition so I gave him scrap value and brought it home. Its been sat on my drive for the last 6 weeks until I could get it booked in for its test but its been started up a few times. It can be a bit smokey on start up, usually grey, but goes after a minute or so, found out it hasn't been serviced in the last 50k since timing belt was done when he bought it so full filter and fluid change done and 10 litres of fresh fuel with a shot of dipetain in to clean the system. Now it ran perfect when I drove it home, no issue. Day of the mot it went for a nice healthy few laps round the village to get it nice and warm for the test, a couple of times there was a blip/loss in power below 2,000 rpm but just thought it was due to not having a good run. Left at test centre then went to pick it up. Got in, the clutch pedal issue had returned ( no pressure in pedal, few pumps to get it back) but as I set off... Nothing, wouldn't rev up sounding like a tractor. Limped it home on clutch ( just a few hundred yards from garage) checked injector plugs, fine. Egr off and cleaned still nothing. If you keep throttle on it starts to increase revs at a snails pace and throw a load of grey and white smoke out of exhaust then from swirl flaps.( noticed the flap bar was off at this point as well.) Im assuming it's not a fuelling issue at this point more air starvation. Only had a quick look so if any one has any suggestions where to go from here ( will be following air flow route to see if anythings amiss when I get chance) I would be grateful. No eml light on or codes, turbo doesn't kick in but the revs don't reach above 2000 without smoking the street out.
    Last edited by Chris15777; 5th October 2020 at 15:15.

  2. #2
    New Member
    Join Date
    Dec 2019
    Location
    Runcorn
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2007

    Default

    Any lights on the dash?
    And have you tried an ELM327 adaptors (or chinese clone) and the android app "Car Scanner" to get any error codes?

    Mine did something similar - clouds of smoke followed by lump mode. It was started by a hole in the flexi section of the exhaust putting the fuel mix out. Led to completely plugged combi cat/dpf.

    Code was p2279.

    Sent from my Mi Note 10 Pro using Tapatalk

  3. #3
    New Member
    Join Date
    Dec 2019
    Location
    Runcorn
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2007

    Default

    Should add that the codes started AFTER the hole in the flexi section reached a certain size. It's late and I missed that bit in my previous message!

    But I was getting the "no turbo/James Bond smokescreen" intermittently for a couple of weeks before dash lights or codes showing, usually when I stopped at a junction or lights.

    It would make a sort of "clunk" (more a feeling than a noise) and then light smoke would start. Followed by almost no acceleration and huge white clouds of smoke about 2000 rpm.

    Eventually became almost permanent limp/smoke and the smoke got darker and darker - my pet mechanic went on holiday for 10 days at this point and my cards were maxed so no "proper" garage visit.

    Sent from my Mi Note 10 Pro using Tapatalk

  4. #4
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    52 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    i would read the car out first with either tech2 or (sl)op-com... failing that use an ELM327bt dongle and download a program like mentioned before and use that to find what the ecu has logged as a problem... but the physical problems you've already found need to be addressed regardless of the solutions for the logged faults.

    I would address the swirlflap bar, fix it or either get a welded inlet (aka swirlflap delete) and do an egr block (than have it all mapped out and gain some extra BHP in the process.) Than next up would be to replace the flexi , you can find a locale garage that does welding, as they can just cut the old one out and weld a new one on... that should take care off the first problems that can cause smoking...

  5. #5
    New Member
    Join Date
    Oct 2020
    Location
    Doncaster
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 1.9 cdti 150

    Year : 2006

    Default

    Thanks for the replies, went to start it this morning to have a look and it struggles to idle now, think its not worth the full repair bill now, dmf needs doing because its rattling and now this issue, I got it to try and save it from the scrap yard but alas, anyway in answers to your questions, no there are no lights on dash indicating a fault, the exhaust was changed just over a year ago and it had just had its mot ( failed on a tyre and o s handbrake) would've gladly done the dmf with that result. Don't know how long the swirl flap bar has been off, there is a bit of oil sweat in the area and the smoke comes out of them when it finally revs up. I ve got a basic scanner so I'll try it and see if it picks any codes up but I doubt it will without the eml on. I donr like defeat so I have proper given up on it yet but just not had the time to get my hands proper mucky on it yet. It just seems funny how the clutch problem returned and the power issue both appeared after a long run. The master was changed as it was losing pressure and air was getting in when it was bleed. It spent 6 weeks on the drive without any loss, 5 mile drive and it all goes wrong.

  6. #6
    New Member
    Join Date
    Oct 2020
    Location
    Doncaster
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 1.9 cdti 150

    Year : 2006

    Default

    All sorted hopefully, after a little time playing under the bonnet I removed the Map sensor. Totally caked up and blocked with the troublesome oily soot . All cleaned out and she's running again, next job after getting it re mot'd is definitely get manifold cleaned out and swirls plugged up. Then the little matter of a full clutch and dmf.

  7. #7
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    52 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    Quote Originally Posted by Chris15777 View Post
    Then the little matter of a full clutch and dmf.
    If i was in your shoes i would just buy a new clutch + flywheel kit and clutch slave cylinder... than DIY it to keep costs down...

  8. #8
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    52 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    also you can buy a welded intake that has them removed properly all you'll need than is blocking the egr on both sides and have the swirlflaps and egr mapped out, and gain some BHP in the process...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra C 3.0 CDTI - Wont start, clicking starter or solenoid
    By Alexgtr in forum Engine & Drivetrain
    Replies: 6
    Last Post: 4th October 2016, 18:06
  2. help vectra 1.9 cdti 150 wont start had ecu reset oops
    By gabz in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 23rd February 2016, 09:20
  3. vectra 1.9 cdti wont turn over
    By horley in forum Engine & Drivetrain
    Replies: 4
    Last Post: 13th June 2014, 15:12
  4. Vectra cdti 16v wont turn help!!
    By Turbomanrony in forum Engine & Drivetrain
    Replies: 4
    Last Post: 13th February 2013, 23:53
  5. vectra c 1.9 cdti 150 wont rev past 2000
    By safayth1993 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 4th January 2013, 20:08

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •