User Tag List

Thanks Thanks:  0
Likes Likes:  2
Results 1 to 8 of 8

Thread: Zafira B z19dth boost issue

  1. #1
    Regular Member
    Join Date
    Aug 2014
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI

    Engine : 2.2

    Year : 2005

    Default Zafira B z19dth boost issue

    I need some help with a problem I am experiencing.

    Car developed a slight turbo whine and at low rpm/low load. After googling I put this down to a leak at 1 of the gaskets on the turbo. Car was still pulling like a train.

    Then one day taking a drive the car felt very sluggish/laggy (I thought it couldn't been a blocked DPF) and once I got on the dual carriage way I got check engine light and limp mode.

    I am getting fault code P0234-5B Boost Pressure Control Circuit Positive Deviation.

    I did have a brief look under the bonnet but am not sure what to look for. Can't see any obvious damage to hoses/vacuum lines.

    Here is a link for live data recorded to trigger check engine light and limp mode.

    Any advice would be great thanks.
    Last edited by cheese_za; 1st August 2020 at 09:48.

  2. #2
    Regular Member
    Join Date
    Sep 2018
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Clean the map sensor and check the pipes going to the boost control solinoid as well as the solinoid itself.


    Sent from my iPhone using Tapatalk

  3. Likes cheese_za liked this post
  4. #3
    Regular Member
    Join Date
    Aug 2014
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI

    Engine : 2.2

    Year : 2005

    Default

    Quote Originally Posted by davoc220 View Post
    Clean the map sensor and check the pipes going to the boost control solinoid as well as the solinoid itself.


    Sent from my iPhone using Tapatalk
    Do you mean MAF sensor? If not, what's the MAP sensor.

    Will check the pipes going to the boost control solenoid. I replaced that about 2 years ago.

  5. #4
    Regular Member
    Join Date
    Sep 2018
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Zafira B z19dth boost issue

    The map sensor is on the inlet manifold, it’s inclined to coke up


    Sent from my iPhone using Tapatalk

  6. Likes cheese_za liked this post
  7. #5
    Regular Member
    Join Date
    Aug 2014
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI

    Engine : 2.2

    Year : 2005

    Default

    Quote Originally Posted by davoc220 View Post
    The map sensor is on the inlet manifold, it’s inclined to coke up


    Sent from my iPhone using Tapatalk
    Thanks. Will check that now.

    Can I use carb and brake cleaner on it?

  8. #6
    Regular Member
    Join Date
    Sep 2018
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Brake cleaner should be fine, if there’s any deposits on the sensor mesh, use a cotton bud to gently take it off tho


    Sent from my iPhone using Tapatalk

  9. #7
    Regular Member
    Join Date
    Aug 2014
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI

    Engine : 2.2

    Year : 2005

    Default

    I have checked the MAP sensor, it seems fine:

    IMG_20200802_163116.jpg

    I removed the boost solenoid. It is not blocked, and it actuates when current is applied to it. Vacuum lines refitting snugly.

    Is the next step turbo removal?

    Also, is the car still ok to drive like this?

  10. #8
    Admin & Membership Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Post Thanks / Like
    Mentioned
    100 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    To me, that map sensor looks dirty

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zafira Z22YH Fuel Issue
    By Adamant in forum Engine & Drivetrain
    Replies: 3
    Last Post: 4th March 2020, 22:02
  2. Z19dth issue
    By new_gen in forum Engine & Drivetrain
    Replies: 3
    Last Post: 28th July 2018, 21:58
  3. Losing boost Z19DTH
    By nikolat in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 6th June 2018, 06:36
  4. Zafira Z19DTH cutting out
    By cheese_za in forum Engine & Drivetrain
    Replies: 7
    Last Post: 16th February 2017, 05:15
  5. For Sale: Boost sensor Z19DTH
    By Wilson118 in forum Parts for sale
    Replies: 2
    Last Post: 15th January 2016, 09:14

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •