User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 1.9 cdti 150 advice needed 😭

  1. #1
    New Member
    Join Date
    Dec 2019
    Location
    Devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Zafira b 1.9cdti 150

    Trim : Design

    Engine : 1.9cdti 150

    Year : 2006

    Mileage : 117.000

    Default 1.9 cdti 150 advice needed 😭

    Zafira 1.9 cdti 150, Every other drive I get the EML and "p2279 air intake system leak" , I have what I can only describe as a power surge and hesitation under heavy load . I've replaced the map sensor , boost control valve, egr valve , and checked over the pipework and found no splits . The inlet and swirls where done a month before I bought it and I've only had it a few months . Under normal load it's fine but I'll still get the light and code , I'm at a loss as to what do next 🙄🙄🙄 HELP ME PLEASE FOR THE LOVE OF GOD !!!!!!

  2. #2
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    42 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    Clean both maf and map sensors also check all intercooler for cracks... and I'm quite sure I already told you this except for the map and mag sensor... clean them or replace them... if you can't find any boost leaks... but the intercooler can be the problem the only way to really test that is to do a pressure test...

  3. #3
    New Member
    Join Date
    Dec 2019
    Location
    Devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Zafira b 1.9cdti 150

    Trim : Design

    Engine : 1.9cdti 150

    Year : 2006

    Mileage : 117.000

    Default

    Quote Originally Posted by northpole View Post
    Clean both maf and map sensors also check all intercooler for cracks... and I'm quite sure I already told you this except for the map and mag sensor... clean them or replace them... if you can't find any boost leaks... but the intercooler can be the problem the only way to really test that is to do a pressure test...
    Yes you have , just posting in a more relevant spot

  4. #4
    Regular Member
    Join Date
    Jan 2016
    Location
    buckley
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : design

    Engine : 1.9 150 diesel

    Year : 56

    Default

    boost sensor on the front the small pipes on it somtimes fail and can hard to find so best to replace them also the sensor its self can fail

  5. #5
    Midlands - Head case Organiser Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Post Thanks / Like
    Mentioned
    279 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    Quote Originally Posted by paula9568 View Post
    boost sensor on the front the small pipes on it somtimes fail and can hard to find so best to replace them also the sensor its self can fail
    There is no boost sensor on the front or around the front of the engine unless you class the inlet side as the front in which case there are no pipes on it as seals into the inlet manifold.
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 255/300
    Eibachs B8's, fully loaded factory options

    Tech2 & MDI diagnostics

  6. #6
    Regular Member
    Join Date
    Jan 2016
    Location
    buckley
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : design

    Engine : 1.9 150 diesel

    Year : 56

    Default

    ok the boost control solinoid

  7. #7
    Midlands - Head case Organiser Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Post Thanks / Like
    Mentioned
    279 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    Quote Originally Posted by paula9568 View Post
    ok the boost control solinoid
    He said it’s a air leak issue and he has already replaced the bcs so afaik irrelevant to the posted issue.

    OP have you cleaned the MAF and any other sensors new or otherwise? Also what make of parts have you been using?
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 255/300
    Eibachs B8's, fully loaded factory options

    Tech2 & MDI diagnostics

  8. #8
    New Member
    Join Date
    Dec 2019
    Location
    Devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Zafira b 1.9cdti 150

    Trim : Design

    Engine : 1.9cdti 150

    Year : 2006

    Mileage : 117.000

    Default

    Quote Originally Posted by Dog_Book View Post
    There is no boost sensor on the front or around the front of the engine unless you class the inlet side as the front in which case there are no pipes on it as seals into the inlet manifold.
    There is on the zafira , behind the drivers side fog light , which I've already replaced along with the map sensor on the manifold

  9. #9
    Midlands - Head case Organiser Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Post Thanks / Like
    Mentioned
    279 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    Quote Originally Posted by Tess tickle View Post
    There is on the zafira , behind the drivers side fog light , which I've already replaced along with the map sensor on the manifold
    Might be a good idea to post pics then as that's completely different to the Vectra set up which im surprised about. You haven't answered my other 2 questions either?

    **Ive checked the intake system and cannot see any such sensor, in relation to the fog light the route of the pipework looks like it would miss the fog light area as its upside down to the Vectra all the pipework is at the top not the bottom.
    Last edited by Dog_Book; 7th December 2019 at 22:20.
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 255/300
    Eibachs B8's, fully loaded factory options

    Tech2 & MDI diagnostics

  10. #10
    New Member
    Join Date
    Dec 2019
    Location
    Devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Zafira b 1.9cdti 150

    Trim : Design

    Engine : 1.9cdti 150

    Year : 2006

    Mileage : 117.000

    Default

    Quote Originally Posted by Dog_Book View Post
    Might be a good idea to post pics then as that's completely different to the Vectra set up which im surprised about. You haven't answered my other 2 questions either?

    **Ive checked the intake system and cannot see any such sensor, in relation to the fog light the route of the pipework looks like it would miss the fog light area as its upside down to the Vectra all the pipework is at the top not the bottom.
    Yes laid out differently to the vectra , hard work finding pics online pin pointing what's what as mostl of them are of the vectra �� Bosch parts are what I've replaced with , haven't touched the MAF yet , bcv and relevant Pipeworks runs out of the turbo and one down from throttle body to behind the drivers fog , mounted just above the horns . Next step then maf clean and or pressure test

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 cdti 150 advice needed 😭
    By Tess tickle in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 7th December 2019, 12:32
  2. Vectra CDTI 150 Front Shocks needed .. Advice needed
    By aps in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 20th September 2015, 21:35
  3. Vectra CDTI 150 Front Shocks needed .. Advice needed
    By aps in forum Handling & Braking
    Replies: 2
    Last Post: 20th September 2015, 19:34
  4. Advice needed for my sri cdti 150
    By simmo3187 in forum Engine & Drivetrain
    Replies: 18
    Last Post: 3rd June 2011, 18:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •