User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Lack of Power Below 2k Vectra C CDTI

  1. #1
    New Member alan p's Avatar
    Join Date
    Mar 2017
    Location
    Wiltshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9 CDTI

    Year : 2006

    Mileage : 138247

    Question Lack of Power Below 2k Vectra C CDTI

    I have an problem with my Vectra, when i first start i get the spanner light which goes out after a few minutes but i have very little power untill the revs get up to around 3,000 then it takes off like a train, when the car gets hot which can take awhile the spanner light comes on and i have no power above 3,000 but the bottom end response is better, if i turn the car off and on again the spanner light goes out but the check engine light comes on and the car runs better ie better bottom end with power above 3,000. I have cleaned the EGR added the Fiat gasket, changed the boost sensor put a fuel cleaner through the tank and checked the vac pipes the manifold flaps seam to be working and the rod is in place any ideas as im running out of options

  2. #2
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2t

    Trim : standard

    Engine : z20net

    Year : 08

    Mileage : 32000

    Default

    Have you thought of checking the car for any fault codes?

  3. #3
    New Member alan p's Avatar
    Join Date
    Mar 2017
    Location
    Wiltshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9 CDTI

    Year : 2006

    Mileage : 138247

    Default

    I have and there is nothing logged !!

  4. #4
    Regular Member
    Join Date
    Mar 2013
    Location
    Scotland, North East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Saab 9-3 (Vectra C in disguise)

    Trim : Linear Sport

    Engine : 1.9 TiD 150

    Year : 2005

    Default

    boost sensor aka MAP or boost solenoid?

    Spray some soapy water on the flaps, see if you get any bubbles

    Do you get any screeching / squealing noises?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra C 1.9 CDTi 150 lack of power
    By BenLothian in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 19th March 2019, 09:11
  2. Vectra cdti 150 smoking and lack power below 2k revs
    By Jay_61279uk in forum Vectra C / Signum Troubleshooting
    Replies: 14
    Last Post: 3rd November 2018, 21:26
  3. Vectra C 150 CDTi Lack of Power
    By sclarkson82 in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 18th March 2011, 21:07
  4. Lack Of Power (2004 1.9 cdti 8V)
    By user999998 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 2nd June 2009, 09:03
  5. cdti 150 lack of power
    By michael cummings in forum Diesel Engine related
    Replies: 3
    Last Post: 8th February 2009, 20:44

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •