User Tag List

Thanks Thanks:  0
Likes Likes:  1
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: canbus faults. ABS, ECM, power stearing all loosing canbus

  1. #1
    New Member
    Join Date
    Jul 2014
    Location
    Bangalore
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Saloon

    Trim : Saloon

    Engine : X22SE

    Year : 2002

    Default canbus faults. ABS, ECM, power stearing all loosing canbus

    Hello All,

    For quite some time i am facing issues with my Vectra c Z22SE.

    sometimes while driving or sometimes after a drive the power steering, battery lights and abs lights come up.

    Here is a recording of it.
    https://youtu.be/Q1NkhuFpbjg

    Identifier: 0x0501
    VIN: W0L0ZCF6931080250
    Hardware number:12563556
    Motor type: Z22SE
    Part Number:12583487
    Software version number: 00BFF56B
    Programming Date: 20030406
    Hardware key number: S001007222
    System description: MOTOR0100
    Type approval number: G03004
    Alpha code: TY
    Hardware manufacturer system name: MOTOROLA
    Software version: 41106
    ECU variant coding: 0x00003800




    Total number of fault codes: 1


    U2108 - CAN-Bus no Communication with ABS/TC
    (00) - Present



    similar codes are present in other modules too.

    When i tap the ABS plug or use horn couple of time things restore for while. This has become a nagging problem and sometimes the car won't start unless I tap the ABS plug.

    Any help on this would be appreciated.

    Regards
    Kishore

  2. #2
    Regular Member Daywalker's Avatar
    Join Date
    Aug 2007
    Location
    Virbaliskiu km, Kaunas raj
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Volvo V50

    Trim : SE Lux

    Engine : 1.6 Drive

    Year : 2011

    Default

    Quote Originally Posted by krishna View Post
    When i tap the ABS plug or use horn couple of time things restore for while. This has become a nagging problem and sometimes the car won't start unless I tap the ABS plug.

    Any help on this would be appreciated.

    Regards
    Kishore
    In that bit is your answer you need to take the ABS plug off and clean the contacts with cleaner and then hopefully your problem will be solved

  3. #3
    New Member
    Join Date
    Sep 2015
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra VXR

    Trim : VXR

    Engine : 28NEH

    Year : 07

    Default

    Didn’t the early ones have bad connections or broken wires on abs plug ???

  4. #4
    New Member
    Join Date
    Jul 2014
    Location
    Bangalore
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Saloon

    Trim : Saloon

    Engine : X22SE

    Year : 2002

    Default

    Quote Originally Posted by Daywalker View Post
    In that bit is your answer you need to take the ABS plug off and clean the contacts with cleaner and then hopefully your problem will be solved
    I did clean the connector and did all that, still the problem persists.

  5. #5
    New Member
    Join Date
    Jul 2014
    Location
    Bangalore
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Saloon

    Trim : Saloon

    Engine : X22SE

    Year : 2002

    Default

    Quote Originally Posted by Jon1796 View Post
    Didn’t the early ones have bad connections or broken wires on abs plug ???
    Is it? What is solution? replace the whole wiring loom? i was thinking of cutting off the connector with few inches of wire and use connector from a donor car. any suggestions or advice on this?


    Regards
    Kishore

  6. #6
    Regular Member
    Join Date
    Apr 2008
    Location
    West Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'd be more inclined to clean the connections first (using electrical switch cleaner, not WD40) as it's a lot quicker and easier to do.

  7. Likes tolga464 liked this post
  8. #7
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    Quote Originally Posted by NickT View Post
    I'd be more inclined to clean the connections first (using electrical switch cleaner, not WD40) as it's a lot quicker and easier to do.
    WD40 is just the brand name nowadays, they have silicone spray, electrical contact cleaner, chain lubricant, copperspray etc etc etc all sold under the same brand name WD40.

  9. #8
    New Member
    Join Date
    Sep 2015
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra VXR

    Trim : VXR

    Engine : 28NEH

    Year : 07

    Default

    V replaced by chopping off and rewiring but a pain of a job in the space.
    You can undo the back cover of abs plug carefully try to find faulty wire and fix that rather than the whole plug !!!
    But what does confuse me is, you used horn a few times and it worked again.

  10. #9
    Regular Member
    Join Date
    Apr 2008
    Location
    West Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by northpole View Post
    WD40 is just the brand name nowadays, they have silicone spray, electrical contact cleaner, chain lubricant, copperspray etc etc etc all sold under the same brand name WD40.
    If you mention "WD40", then generally people will refer to the Water Displacement lubricant. I appreciate it's a brand name, so I emphasised an electrical switch cleaner for the task in hand.

  11. #10
    Midlands - Head case Organiser Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    216 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    Quote Originally Posted by NickT View Post
    If you mention "WD40", then generally people will refer to the Water Displacement lubricant. I appreciate it's a brand name, so I emphasised an electrical switch cleaner for the task in hand.
    I can also vouch that wd40 contact cleaner is a useful as a vxr owner that uses facebook in a episode of university challenge so have now binned it and acquired some RS electrical contact cleaner as its the real thing.
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 245/300
    Eibachs B8's, fully loaded factory options

    https://www.vectra-c.com/forum/calendar.php

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. half canbus to full canbus
    By MORGIE8153 in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 20th May 2017, 22:42
  2. intermittent canbus faults any ideas
    By phillcdti in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 31st December 2014, 23:57
  3. Full Canbus - Half Canbus. Whats the difference?
    By M65 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 29th November 2013, 09:02
  4. 2004 Signum 2.0 DTI loosing power and showing faults
    By 1ctchris in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 1st September 2010, 12:41
  5. Whats the difference between a canbus car and a half canbus car
    By chuckleuk in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 1st August 2010, 21:07

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •