User Tag List

Thanks Thanks:  0
Likes Likes:  5
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Loud turbo and slight overheating

  1. #1
    VIP-Member
    Join Date
    Jul 2018
    Location
    BIRMINGHAM
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Life

    Engine : Z19DT

    Year : 07

    Default Loud turbo and slight overheating

    I've looked through Google and the forums and can't find this combination of problems so hoping I can get some help here.

    Had my 1.9 cdti 120 for 2 and a half months now and since getting brave with it (coming form a 1.2 corsa) and seeing what it can do, I was never able to get over 3.5k revs as it went to limp mode once I did. Tried things like cleaning the egr and map sensor to no avail.
    Fast forward to getting it remapped and teapot suggested I look at the boost solenoid before applying the new map. Took the solenoid off (dropped it) and checked/reseated the 2 tubes coming off it. Took it for a test drive, lo and behold I could finally reach the red line! I was so chuffed that I pulled in to a layby in the dual carriageway I tested it on and wrote teapots new file. Drove it off and loved the extra 40bhp I was measuring.

    Kept the new map on for a few days but noticed I had drastically dropped mpg (42 down to 25) and the turbo was whiny but I attributed that to increased pressure. I wasn't happy with either of these and decided I'd go back to stock map until I fit the fmic I want as I thought part of the problem would be the charge temp.

    Fast forward again to today and for the last 2 commutes home which are no more than 20 miles, I've hit 95+ Celsius engine and my turbo is still whining despite being at stock pressures. Have I killed my turbo or engine?
    My theory is there is a problem with my turbo and it is causing early detonation which is in turn causing the high temp. Are the 2 problems related?

  2. #2
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2t

    Trim : standard

    Engine : z20net

    Year : 08

    Mileage : 32000

    Default

    Have you discussed this with Teapot in private before asking on the forum?

  3. Likes Teapot liked this post
  4. #3
    Midlands - Head case Organiser Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    210 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    Quote Originally Posted by nikroc View Post
    Have you discussed this with Teapot in private before asking on the forum?
    To be fair its irrelevant to the mapping as Teapots maps are spot on and have been for many years.

    The above issues could be a number of other things like failed injectors failed IC aux belt idlers and others
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 245/300
    Eibachs B8's, fully loaded factory options

    https://www.vectra-c.com/forum/calendar.php

  5. Likes Teapot liked this post
  6. #4
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2t

    Trim : standard

    Engine : z20net

    Year : 08

    Mileage : 32000

    Default

    I know but aside from his mapping skills he's also pretty clued up on these engine's...aint he?

  7. Likes Teapot liked this post
  8. #5
    VIP-Member
    Join Date
    Jul 2018
    Location
    BIRMINGHAM
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Life

    Engine : Z19DT

    Year : 07

    Default

    Quote Originally Posted by nikroc View Post
    Have you discussed this with Teapot in private before asking on the forum?
    No because as dog_book says, it's not caused by or related to the map as there was an underlying issue before the map and there is still an issue after removing it so I'm looking for guidance on how to move forward

  9. Likes Teapot liked this post
  10. #6
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2t

    Trim : standard

    Engine : z20net

    Year : 08

    Mileage : 32000

    Default

    I must have somehow missed the 'problems' being there before the map in your post. No worries.

  11. #7
    Midlands - Head case Organiser Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    210 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    Quote Originally Posted by nikroc View Post
    I know but aside from his mapping skills he's also pretty clued up on these engine's...aint he?
    This is also true
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 245/300
    Eibachs B8's, fully loaded factory options

    https://www.vectra-c.com/forum/calendar.php

  12. #8
    VIP-Member
    Join Date
    Jul 2018
    Location
    BIRMINGHAM
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Life

    Engine : Z19DT

    Year : 07

    Default

    I'll see if he can offer any assistance.
    In the meantime, I've just been for a 15 minute drive to the shops. On the way there I had the heating on full and it heated up which I guess rules out the water pump and maybe the thermostat?
    On the way back, I pulled off with the temp gauge at the bottom, put my foot down for 15 seconds and it shot up to 87-88 in that time, drove home under 1100rpm the rest of the way and it went down to 80.

  13. #9
    VIP-Member
    Join Date
    Jul 2018
    Location
    BIRMINGHAM
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Life

    Engine : Z19DT

    Year : 07

    Default

    I've looked through the service history and the last oil change, despite being 12k miles ago, was fine in Feb 2015 so I think I'll do that today.
    I need to get the bumper off anyway as my horn's not working so I'll look at the rad and intercooler whilst I'm in there.

  14. #10
    VIP-Member
    Join Date
    Jul 2018
    Location
    BIRMINGHAM
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Life

    Engine : Z19DT

    Year : 07

    Default

    Finally got round to looking at this today and found the issue to be the EGR, or it's piping to be exact. There was a bolt missing at the valve end so there was an air leak which has been resolved but at the manifold end the pipe has previously been welded and that's now broke.
    Think I'm going to go the blanking route instead of refitting, already got the map to delete it once the plates fitted so that's next weekends job, hope it isn't too much work for me

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. turbo isnt working and loud squeal
    By Vectra kris in forum Engine & Drivetrain
    Replies: 9
    Last Post: 1st May 2015, 21:48
  2. Vectra C Turbo overheating
    By SriTurbo1 in forum Vectra C / Signum Troubleshooting
    Replies: 17
    Last Post: 9th October 2012, 08:03
  3. 1.9cdti turbo loud whistle !!
    By djspenna in forum Engine & Drivetrain
    Replies: 4
    Last Post: 15th September 2011, 15:12
  4. How loud is your turbo?
    By bigdave1701 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 30th July 2011, 23:58
  5. 2.2 dti loud turbo
    By vecdesign in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 19th April 2011, 21:27

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •