User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: y30dt juddering/smoking/hesitating

  1. #1
    New Member
    Join Date
    Sep 2018
    Location
    Lisbon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Caravan

    Engine : Y30dt

    Year : 2003

    Default y30dt juddering/smoking/hesitating

    hi guys!
    i own a caravan with a y30dt engine with 257.000km(159.000miles).
    at first, when i bought it, it was fine, pulling great,no smoke, nothing, it was healthy.
    but some weeks later, she started with this symptoms:

    1) hesitating for about 1 sec when floor it. turbo whistles good like in full gas but doesnt move.then it goes with lots of smoke.

    2) juddering when i dont push too hard on the gas. a little smoke too.

    3) rpm needle moves sometimes on idle , start to oscilate and i can hear the egr doing his work. (bad work probably).

    4)fuel consumption stays equal like in first days.

    5)no warning lights displayed.

    note that i did basic maintenance (all filters, and oil) and when the car started with this symptoms i add injector cleaner from stp and it improve a little for 2 ,3 weeks with small juddering ,barely noticed ,above 1500rpm with no hesitation .now ,he returned to the beggining of the problem.

    so ,can someone give me some lights what to look for first? i tought on egr or maybe scv starting to fail.

    any help would be apreciated.

    cheers!

  2. #2
    Regular Member
    Join Date
    Jun 2015
    Location
    Riga
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elite custom

    Engine : 3.0

    Year : 2005

    Mileage : 95kMiles

    Default

    Black smoke is most likely is piping has a hole somewhere. Or a maf problem

  3. #3
    Regular Member
    Join Date
    Apr 2008
    Location
    West Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Is the engine management light on/ do you have any fault codes?

    Have you done a visual check for any split turbo houses?

  4. #4
    New Member
    Join Date
    Sep 2018
    Location
    Lisbon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Caravan

    Engine : Y30dt

    Year : 2003

    Default

    I did check all hoses and i didnt find any leak or something.
    No codes found or spanner+car Light appeard.
    Today i went to a opel dealer. The car was way worse. I couldnt pull above 2500 rpm, even in full throttle. Starts to juddering with no power at all. If i go Light on the gas pedal she struggles a bit but increase rpm. But then, it judders and i cant drive it or going uphill.
    The smoke is Grey, no Black smoke at all.
    It cranks fine everytime but idle stays bouncy.
    I asked for service history and the previous owner only bought the car and no more service had be done. So problably, scv, software updates and that stuff wasnt applied to the ecu. I Will wait now for the results of diagnosctics and Will see...but If you have any ideias, tell me!
    Thanks!

  5. #5
    Regular Member
    Join Date
    Apr 2008
    Location
    West Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If the symptoms have only started since you did the service, and this included the fuel filter, is be inclined to check the fuel filter again for the seal, the internal o rings off the seal and that the fuel system was bled correctly to remove all air.

    On my z30 I do this by bleeding fuel from the top most part of the fuel system at the top of the engine.

  6. #6
    New Member
    Join Date
    Sep 2018
    Location
    Lisbon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Caravan

    Engine : Y30dt

    Year : 2003

    Default

    It started 2 or 3 days before i change the fuel filter. I did check the fuel filter housing and It was full of diesel to the top. So i think its all ok on there.

  7. #7
    New Member
    Join Date
    Sep 2018
    Location
    Lisbon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Caravan

    Engine : Y30dt

    Year : 2003

    Default

    Update


    I added some 2stroke oil on the fuel. The car ran nicely but after a few miles, it started with hesitations again. Im considering scv being faulty

  8. #8
    Regular Member
    Join Date
    Apr 2008
    Location
    West Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by NickT View Post
    If the symptoms have only started since you did the service, and this included the fuel filter, is be inclined to check the fuel filter again for the seal, the internal o rings off the seal and that the fuel system was bled correctly to remove all air.

    On my z30 I do this by bleeding fuel from the top most part of the fuel system at the top of the engine.
    Did you bleed the fuel system from the top most part of the engine?

  9. #9
    New Member
    Join Date
    Sep 2018
    Location
    Lisbon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Caravan

    Engine : Y30dt

    Year : 2003

    Default

    Nope. I've only changed the fuel filter, started the car after with some brake cleaner. I didnt bleed anything. When tou say the top part of the engine, what zone are you talking about?

  10. #10
    Regular Member
    Join Date
    Apr 2008
    Location
    West Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Follow the fuel pipe from the filter to the engine. On my z30dt it goes upwards and has a connector you can unclip. It's next to the air filter box. I use a clarke machine mart oil tranafer syringe to draw the fuel upwards to this area a few times until there's no more bubbles. It eliminates any air lock.

    If you've put 2 stroke oil in the fuel it may have temporarily made the fuel pipe connector on the pick up in the fuel tank good. This can leak air in the fuel and aerate it. I cleaned mine up and used silicon spray to reseal (spayed on the outside of the inner pipe, not in the pipe).

    I'm trust trying to save you a few quid and time dismantling the engine where it could be something straightforward.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine hesitating, remap?
    By jaygsi in forum Engine & Drivetrain
    Replies: 8
    Last Post: 21st August 2017, 16:31
  2. Hesitating/juddering
    By TwitchyWizard in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 1st July 2013, 08:17
  3. hesitating - limp mode
    By madman in forum Engine & Drivetrain
    Replies: 10
    Last Post: 31st July 2010, 05:19
  4. hesitating
    By madman in forum Engine & Drivetrain
    Replies: 4
    Last Post: 16th July 2010, 18:37
  5. HELP!... v6 CDTi hesitating, now EML on
    By Phatty in forum Engine & Drivetrain
    Replies: 273
    Last Post: 23rd March 2010, 17:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •