User Tag List

Thanks Thanks:  0
Likes Likes:  1
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Load Clanking Sound On Cold Start-up??

  1. #11
    Regular Member northpole's Avatar
    Join Date
    Apr 2016
    Location
    Ipswich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SXI limited edition

    Engine : 2.0 16v DTI

    Year : 2003

    Mileage : 140000

    Default

    when was the last time you did an oil change? IMHO if it has been at least 6 months ago might i advise an engine oil flush... don't forget to replace the oil filter too.. that way you make sure the oil is clean and it will give better cold start protection... just make sure you use the right grade oil.

  2. #12
    Midlands - Head case Organiser Dog_Book's Avatar
    Join Date
    Oct 2013
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    195 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : VXR

    Engine : Z28NEH

    Year : 07

    Default

    Nothing similar covered in the troubleshooting section at all then?
    Vectra VXR estate 2007 Sapphire Black
    Teapot Tuned 245/300
    Eibachs B8's, fully loaded factory options

    https://www.vectra-c.com/forum/calendar.php

  3. Likes stokesmoker liked this post
Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Limp Mode - Turning Left/Under Load/Cold
    By Jacksnowdon in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 30th April 2016, 20:33
  2. random cold knock/tick sound when cold - 1.9 cdti
    By valvelift in forum Engine & Drivetrain
    Replies: 4
    Last Post: 18th January 2013, 18:59
  3. smoke at cold cold start
    By azacbr6 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 5th December 2012, 18:23
  4. Clanking On Start-Up
    By Si-SRI in forum Engine & Drivetrain
    Replies: 3
    Last Post: 5th March 2011, 21:13
  5. Full Load, Deep Grind sound when braking?
    By kktdragon in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 10th January 2009, 14:22

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •