User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Fault F displayed on Radio LCD

  1. #1
    Regular Member
    Join Date
    Apr 2014
    Location
    ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra sri 150

    Trim : sri

    Engine : 150

    Year : 2008

    Default Fault F displayed on Radio LCD

    Hi..
    Need help. My 08 Vectra 150 bhp 1.9 sri stopped dead on the side of the road with warning lights emitted. Tried to start but kept turning over. Managed to push the car off the road and now its not turning over at all. I've noticed F displayed on the radio LCD and when I've the key turned to on the engine management light doesn't come on at all( usually flashes briefly)
    Also have noticed that my gauges aren't working either fuel and engine temp.

  2. #2
    Full Member
    Join Date
    Jan 2016
    Location
    buckley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : design

    Engine : 1.9 150 diesel

    Year : 56

    Default

    the f displayed i think is the outside temp sensorand the rest could be faulty cim try the conector on your abs unit another thing u could try is disconect your battery for about 30 mins

  3. #3
    Regular Member
    Join Date
    Apr 2014
    Location
    ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra sri 150

    Trim : sri

    Engine : 150

    Year : 2008

    Default

    HI Outside temp gauge is working correctly, The F fault is displayed beside the mileage and MPG on the LCD screen. Ill post a pick up later of the fault.

  4. #4
    Regular Member
    Join Date
    Apr 2014
    Location
    ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra sri 150

    Trim : sri

    Engine : 150

    Year : 2008

    Default

    Tried the OBD2 scanner and not its unable to read any codes now its unable to connect to the car. Looks like no power getting to the ecru. All fuses are Okay


    8F10BD23-E538-46E1-B284-875147B96FA0.jpg
    712B2DEC-4246-4F3F-A95B-F18705CCAAA4.jpg

  5. #5
    Full Member pattz123's Avatar
    Join Date
    Feb 2009
    Location
    Motherwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Vectra Estate

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 83k

    Default

    F is for Flat battery hence why theres not enough power going to ur ecu's to get fault codes, as for the engine cutting out possibly timing belt gone, alternator or may be loose battery connection. Hope u get it back running soon.

  6. #6
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    309 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    Lol that's a good one.! Not heard of that before. It has lost comms with the engine ecu which is why it displays F and also explains why it's not cranking over and also why you cannot communicate via obd. Do check your battery voltage is good then check things like abs plug and power steering plug as the high speed canbus runs through it
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  7. #7
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    309 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    Also does the fuel gauge read or remain at zero?
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  8. #8
    Regular Member
    Join Date
    Apr 2014
    Location
    ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra sri 150

    Trim : sri

    Engine : 150

    Year : 2008

    Default

    Okay put jump leads on and still got F fault on the LCD. Checked relay 7 and it's working.
    All instruments are still dead. Can't find the location of the ECU any ideas??

  9. #9
    Full Member
    Join Date
    Jan 2016
    Location
    buckley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : design

    Engine : 1.9 150 diesel

    Year : 56

    Default

    behind the front bumper just below the headlight on the driver side

  10. #10
    Full Member
    Join Date
    Jan 2016
    Location
    buckley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : design

    Engine : 1.9 150 diesel

    Year : 56

    Default

    have u looked in the how tos under general eletrics instruments failure checks

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Safeguard Displayed on radio
    By tommyd in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 18th January 2014, 09:41
  2. Radio fault
    By jamiedvvt in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 10th February 2013, 16:43
  3. AM Radio Fault
    By exclusive07 in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 12th July 2010, 12:56
  4. CDR2005 Radio / Panel Display Fault
    By born to be in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 2nd July 2010, 01:19
  5. aftermarket radio - fault light on
    By the-ferret in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 3rd April 2009, 19:52

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •